Closed Bug 1428735 Opened 2 years ago Closed 2 years ago

Credit card - On https://www.check24.de credit card autofill doesn't work

Categories

(Toolkit :: Form Autofill, defect)

59 Branch
defect
Not set

Tracking

()

RESOLVED INVALID
Tracking Status
firefox59 --- affected

People

(Reporter: Ovidiu, Assigned: selee)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [form autofill:V2][Misc.])

Attachments

(2 files)

Affected versions]:

Tested on Nightly 59.0a1(2018-01-07)

[Affected platforms]:

Tested on Mac OS X 10.12, Windows 10

[Steps to reproduce]:

Prerequisites:
 1. use VPN to connect to a Germany server. 
 
 STR:

1. Go to https://www.check24.de and buy an item and proceed until you are in the credit-card section.
2. Double click on the "Kontonummer" or "Bankleitzahl" fields. 


[Expected result]:

The autofill credit card suggestions are displayed. 

[Actual result]:

Nothing happens. 

NOTE: Here is a video of the actual result: https://streamable.com/ddgl0
Whiteboard: [form autofill: V2]
Hi Ovidiu,

I follow the shopping cart steps in check24.de, and I can not see the page you provided.

In the attachment, it looks both credit card and address can be filled by FormAutofill feature.

Could you help me to reproduce the issue that you see? Thank you.
BTW, I used VPN to reproduce this issue.
Hello Sean,

From what I see we have different URL's, the one from my screen recorder and yours from the print screen.

Here is the link that I used: https://dsl.check24.de/8ca062bf1a571a814a2fa9e9ef753cfd/app/form/register/api/9ee8820af1b27e951937fcf4da370c09/Address/  

If you need to log in you can use my test account: 

email: mozillatest1234@yahoo.com
Password: Costi438242

I verified this again and the behavior is the same.
Whiteboard: [form autofill: V2] → [form autofill:V2][Misc.]
Per comment 3.
Flags: needinfo?(selee)
Hi Ovidiu,

Thanks for your information. I tried your account, and I find another way to fill the credit card (see the attachment). It did fill properly, so I still can not reproduce the issue what you see. 

Could you record a video for the full steps? Thank you.
Flags: needinfo?(selee)
Flags: needinfo?(ovidiu.boca)
Hello Sean,

Here is a full recording of my steps: https://streamable.com/uist0

I think there is an issue with the site because I checked after "German bank code number format": The country code for Germany is DE. The IBAN check digits 89 validate the routing destination and account number combination in this IBAN. The BBAN is 3704 0044 0532 0130 00, which contains the country-specific details of the account number. The bank identifier is 37040044 and the account number is 0532013000.

There is "Kontonummer" field, this means "account number" and in Preferences in the "Edit Credit Card" we have "Card Number" and I think that there are different things. I also checked with the inspector and I saw that the "Kontonummer" field has this attribute "maxlength ="10" and the card number form autofill form has a minimum of 12 characters. 
Please take a look and tell me your opinion about this.
Flags: needinfo?(ovidiu.boca)
Hello Ovidiu,

Thanks a lot for your recording. https://www.check24.de/dsl/vergleichen/ is the entry to get the page that you mentioned since check24.de owns versatile products.

Just like you mentioned, the section looks like a bank account form instead of credit card one. Besides, we will fill a credit card form only if there are cc-number and cc-exp (or cc-name) in a non-autocomplete form.

Based on the above reason, do you agree that this bug can be marked as resolved/invalid? Thanks.
Assignee: nobody → selee
Status: NEW → ASSIGNED
Hello Sean,

I agree with the idea of marking this as resolved/ invalid.
Hello Ovidiu, Thanks for your comment. :)
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.