Closed Bug 1428862 Opened 2 years ago Closed 2 years ago

Drag space in tab bar is lost if a Persona is used

Categories

(Firefox :: Theme, defect, P3)

x86
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1423851

People

(Reporter: charles.milette, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Attached image bug.gif
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20180102110609

Steps to reproduce:

1. Have Firefox use a titlebar in the customization menu. (browser.tabs.drawInTitlebar = false)
2. Hide the titlebar with Openbox's configuration file.
3. Try to drag the empty space after the tabs with the default theme active.
4. Now set a Persona and try dragging the same space again.

(Firefox Nightly 59.0a1 build 2018-01-02, will update and try to reproduce)


Actual results:

While default theme is active, the window moves around as expected.
When the Persona is active, clicking and dragging does nothing.

See the included gif


Expected results:

The browser should still be dragable while a Persona is active
Can reproduce on 2018-01-08
Can't reproduce on Windows, probably Linux specific.
Tentatively triaged in Toolbars and customization. Please move it if there's a more appropriate component
Component: Untriaged → Toolbars and Customization
OS: Unspecified → Linux
Hardware: Unspecified → x86
Component: Toolbars and Customization → Theme
Blocks: gtktitlebar
Priority: -- → P3
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1423851
You need to log in before you can comment on or make changes to this bug.