Closed Bug 1429054 Opened 2 years ago Closed 2 years ago

browser.sidebarAction.close() doesn't close sidebar from all windows

Categories

(WebExtensions :: Frontend, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1427431

People

(Reporter: rhubscher, Unassigned)

References

()

Details

We implemented a toggle to open and close the sidebar if the toolbar button is clicked [0]

However if multiple windows are open, only the current window sidebar is closed turning the button functionality off.

[0] https://github.com/mozilla/notes/pull/515
I tried this change: https://github.com/mozilla/notes/pull/576

But I get:  sidebarAction.close may only be called from a user input handler
That's by design.
Yes but own can I make a Toolbar button that toggle the sidebar? Can we have a toggle() sidebarAction?
How can I know that the current windows sidebar is closed or open?
We are adding an isOpen (or similar API) in bug 1427431. 

Some of the discussion about opening or closing sidebars automatically has happened in other bugs such as bug 1343817 in a design-decision meeting. Overall we feel it's a user choice what sidebar that they have open per window and the costs of opening and closing sidebars is expensive and confusing. Unfortunately in the past this has been an area bad add-ons have caused users grief.

The ability to show an overlay is bug 1340930, what controls that might have we don't know yet but might be more appropriate.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1427431
isOpen would work for us.
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.