Closed Bug 1429544 Opened 2 years ago Closed 2 years ago

Subdialogs can become larger than the viewport and become hard/impossible to use

Categories

(Firefox :: Preferences, defect, P3)

defect

Tracking

()

RESOLVED FIXED
Firefox 59
Tracking Status
firefox-esr52 --- unaffected
firefox57 --- unaffected
firefox58 --- unaffected
firefox59 --- fixed

People

(Reporter: mixedpuppy, Assigned: myk)

References

Details

(Keywords: regression)

Attachments

(1 file)

In discussing bug 1425535, we were looking at the proxy settings in preferences.

One problem with it is that, if the Firefox window is small enough, you will not be able to access the entire dialog.  

The second, more a suggestion on an approach at making the dialog smaller; rather than using radio buttons for the initial selection, I think a dropdown might work better.  Depending on the dropdown selection, we may show additional options.

bug 1425535 will also have to add some element to the dialog to indicate the extension that has control over those settings.
Correction, bug 1428486 is about the UX for the extension control.
See Also: 14255351428486
This isn't the only dialog that suffers from this problem, but likely one of the worst.

Radio buttons work better for this dialog than a dropdown. A dropdown would still end up showing a large dialog in the Manual Proxy Configuration state, and when the number of options are less than 7 it is generally better to use radio buttons since they allow for quicker visually scanning of the interface and potential outcomes before making a choice.

I would prefer that we make the body of the box vertically flex, keeping the header and footer always visible and showing a scrollbar in the body of the dialog.
Priority: -- → P4
Summary: Proxy config dialog UI issue → Subdialogs can become larger than the viewport and become hard/impossible to use
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1159233
This recently regressed with bug 1379338, so not really a dupe (though related). It's now much worse than in bug 1159233 (which was about really quite (vertically) small windows).

Myk, can you take a look?
Status: RESOLVED → REOPENED
Flags: needinfo?(myk)
Keywords: regression
Priority: P4 → --
Resolution: DUPLICATE → ---
Version: 50 Branch → Trunk
See Also: → 1159233
See Also: 1428486
Before bug 1379338, toolkit/content/xul.css contained the ruleset:

>prefwindow[type="child"] > prefpane > .content-box {
>  -moz-box-flex: 1;
>  overflow: -moz-hidden-unscrollable;
>}

In bug 1379338, I translated that to this ruleset:

>.prefwindow[type="child"] > .prefpane {
>  -moz-box-flex: 1;
>  overflow: -moz-hidden-unscrollable;
>}

But it turns out that the old ruleset wasn't actually being applied, because prefpanes weren't the direct children of prefwindows in the old implementation.  Presumably they had been originally, but at some point they were moved into a deck inside an hbox.

So the rule was obsolete, and I shouldn't have translated it.  The fix is to remove the translation.

(Note: this doesn't address bug 1159233, it only fixes the regression from bug 1379338.)
Assignee: nobody → myk
Status: REOPENED → ASSIGNED
Flags: needinfo?(myk)
Attachment #8941756 - Flags: review?(dao+bmo)
Attachment #8941756 - Flags: review?(dao+bmo) → review+
Duplicate of this bug: 1429711
Giving this a priority to get it off the triage list.
Priority: -- → P3
Duplicate of this bug: 1425729
Pushed by myk@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/1ff4392042af
remove obsolete rule that disables scrolling in pref subdialogs; r=dao
https://hg.mozilla.org/mozilla-central/rev/1ff4392042af
Status: ASSIGNED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
Duplicate of this bug: 1429579
You need to log in before you can comment on or make changes to this bug.