Due to a bug we sometime send a request that got 425 as early-data again

RESOLVED FIXED in Firefox 58

Status

()

P1
normal
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: dragana, Assigned: dragana)

Tracking

58 Branch
mozilla59
Points:
---

Firefox Tracking Flags

(firefox58 fixed, firefox59 fixed)

Details

(Whiteboard: [necko-triaged])

Attachments

(1 attachment)

Comment hidden (empty)
(Assignee)

Comment 1

a year ago
Assignee: nobody → dd.mozilla
Status: NEW → ASSIGNED
Attachment #8941909 - Flags: review?(mcmanus)
Attachment #8941909 - Flags: review?(mcmanus) → review+
(Assignee)

Updated

a year ago
Keywords: checkin-needed
Priority: -- → P1
Whiteboard: [necko-triaged]
(Assignee)

Comment 2

a year ago
Comment on attachment 8941909 [details] [diff] [review]
bug_1429859.patch

Approval Request Comment
[Feature/Bug causing the regression]: bug 1406908
[User impact if declined]: If firefox send some request with tls1.3 early-data, it may happen that server replies with 425 Too Early. Firefox should resend the request but not as early-data. Due to this bug firefox sometimes resend the request in early-data. In that case user will see error 425 as a response.
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: no
[Needs manual test from QE? If yes, steps to reproduce]: no 
[List of other uplifts needed for the feature/fix]:none
[Is the change risky?]: no, it is a one line patch
[Why is the change risky/not risky?]:
[String changes made/needed]:
Attachment #8941909 - Flags: approval-mozilla-beta?
(Assignee)

Updated

a year ago
Blocks: 1406908

Comment 3

a year ago
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/mozilla-inbound/rev/9d7620e3e096
Check mDoNotTryEarlyData in Do0RTT(). r=mcmanus
Keywords: checkin-needed

Comment 4

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/9d7620e3e096
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-firefox59: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Comment on attachment 8941909 [details] [diff] [review]
bug_1429859.patch

Fix an issue which will cause server to reply with 425 too early. Beta58+
Attachment #8941909 - Flags: approval-mozilla-release+
Attachment #8941909 - Flags: approval-mozilla-beta?
Attachment #8941909 - Flags: approval-mozilla-beta+
Duplicate of this bug: 1429221
You need to log in before you can comment on or make changes to this bug.