Closed Bug 1430122 Opened 3 years ago Closed 2 years ago

Custom tab close button is too large compared to the other buttons

Categories

(Firefox for Android :: Custom Tabs, defect, P5)

ARM
Android
defect

Tracking

()

VERIFIED FIXED
Firefox 63
Tracking Status
fennec + ---
firefox59 --- wontfix
firefox60 --- wontfix
firefox61 --- wontfix
firefox62 --- verified
firefox63 --- verified

People

(Reporter: oana.horvath, Assigned: andrei.a.lazar)

References

Details

(Keywords: good-first-bug, Whiteboard: --do_not_change--[priority:high])

Attachments

(3 files, 1 obsolete file)

Attached image previous button.png
Device: Samsung Galaxy S8 (Android 7.0)
Build: Nightly 59.0a1 (2018-01-12);

Steps to reproduce:
1. Open a link in a custom tab (default browser: Nightly).
2. Check the close button.

Expected result:
See the "previous button" screenshot.

Actual result:
The new close button is too large compared to the previous and the other buttons used.
Attached image current button.png
Please help advise. Thanks!
Flags: needinfo?(chuang)
Keywords: good-first-bug
Priority: -- → P2
tracking-fennec: ? → +
Duplicate of this bug: 1431746
[triage] Non-critical.
Priority: P2 → P3
I think it's using the wrong resolution images. Could someone help provide the name of the icon asset (image)? so i could check, thanks!
Flags: needinfo?(chuang)
It seems this was introduced with FF59, it was correct in FF58, at least.
NI Barbara and Andreas, should we fix this for 61 or 62?
Flags: needinfo?(bbermes)
Flags: needinfo?(abovens)
Ideally 61, but I can live with 62 as well.
Flags: needinfo?(abovens)
Whiteboard: [Leanplum][61]
I would like to get this fixed soon, as it's very visible. Can it be prioritized?
Flags: needinfo?(sdaswani)
Andreas, the Softvision team is currently prioritizing the Android O work: https://trello.com/c/izAPXSyJ/506-fennec-target-sdk-version-62 

I can have one of them work on this issue over that work if you feel it is a bigger priority.
Flags: needinfo?(sdaswani) → needinfo?(abovens)
Once that's done, let's tackle this issue.
Flags: needinfo?(abovens)
Vlad, can you please get this on your prioritized list (under the O work)?
Flags: needinfo?(bbermes) → needinfo?(vlad.baicu)
Assignee: nobody → andrei.a.lazar
Flags: needinfo?(vlad.baicu)
Whiteboard: [Leanplum][61] → [priority:low]
Andrei, can you prioritize this immediately after all the API upgrade crash work?
Flags: needinfo?(andrei.a.lazar)
Whiteboard: [priority:low] → --do_not_change--[priority:high]
Sure thing, will fix this ASAP!
Thanks, Andrei.
Re-triaging per https://bugzilla.mozilla.org/show_bug.cgi?id=1473195

Needinfo :susheel if you think this bug should be re-triaged.
Priority: P3 → P5
Comment on attachment 9003173 [details]
Bug 1430122 Custom tab close button is too large compared to the other buttons r?sdaswani

Jim Chen [:jchen] [:darchons] has approved the revision.
Attachment #9003173 - Flags: review+
Flags: needinfo?(andrei.a.lazar)
Keywords: checkin-needed
Please review your patch for this bug. Phabricator says the following:

This revision is not associated with a repository. In order to land, a revision must be associated with a repository on Phabricator.
This diff does not have the proper author information uploaded to Phabricator. This can happen if the diff was created using the web UI, or a non standard client. The author should re-upload the diff to Phabricator using the "arc diff" command.
Flags: needinfo?(andrei.a.lazar)
Keywords: checkin-needed
Resized the close button manually.
Comment on attachment 9004239 [details]
Bug 1430122 Custom tab close button is too large compared to the other buttons.

Vlad Baicu has approved the revision.
Attachment #9004239 - Flags: review+
Flags: needinfo?(andrei.a.lazar)
Keywords: checkin-needed
Pushed by dluca@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c8df42395ed8
Custom tab close button is too large compared to the other buttons. r=VladBaicu
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/c8df42395ed8
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Attachment #9003173 - Attachment is obsolete: true
Verified as fixed on Nightly 63 (2018-29-08).
Devices:
Sony Xperia Z5 Premium (Android 6.0.1)
Google Pixel (Android 9)
Flags: qe-verify+
Seems like a trivial ride-along fix we could take for RC2. Please nominate this for release approval if you agree.
Flags: needinfo?(andrei.a.lazar)
Comment on attachment 9004239 [details]
Bug 1430122 Custom tab close button is too large compared to the other buttons.

Approval Request Comment
[Feature/Bug causing the regression]: Custom tab close button is too large
[User impact if declined]: This causes a bad user experience
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: No
[Is the change risky?]: No
[Why is the change risky/not risky?]: Because it's just an image
[String changes made/needed]: No
Flags: needinfo?(andrei.a.lazar) → needinfo?(ryanvm)
Attachment #9004239 - Flags: approval-mozilla-release?
Comment on attachment 9004239 [details]
Bug 1430122 Custom tab close button is too large compared to the other buttons.

Simple polish fix for custom tabs. Approved for 62 RC2.
Flags: needinfo?(ryanvm)
Attachment #9004239 - Flags: approval-mozilla-release? → approval-mozilla-release+
Flags: qe-verify+
Verified as fixed on RC 62.0 build 2.
Device: Sony Xperia Z5 Premium (Android 6.0.1)
Google Pixel (Android 9)
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Duplicate of this bug: 1488570
See Also: → 1490011
You need to log in before you can comment on or make changes to this bug.