Closed Bug 1430132 Opened 2 years ago Closed 2 years ago

Top Sites context menu button is wrongly displayed when you move the Top Site to the left

Categories

(Firefox :: New Tab Page, defect, P3)

defect

Tracking

()

VERIFIED FIXED
Firefox 60
Iteration:
60.1 - Jan 29
Tracking Status
firefox57 --- unaffected
firefox58 --- unaffected
firefox59 --- wontfix
firefox60 --- verified

People

(Reporter: cmuresan, Assigned: rrosario)

References

Details

Attachments

(3 files)

[Affected versions]:
- Firefox 59.0a1 Build ID 20180111220102

[Affected Platforms]:
- All Windows
- All Mac
- All Linux

[Prerequisites]:
- Have a clean new profile.

[Steps to reproduce]:
1. Start the browser with the profile from prerequisites and open a new profile.
2. Drag the last Top Site to the left and observe the top-right part of the tile.
 
[Expected results]:
- The context menu button is not displayed.

[Actual results]:
- The context menu button remains displayed.

[Notes]:
- The issue is not reproducible if you move the Top Site to the right.
- The issue is also reproducible with the additional options from the Top Sites Edit menu.
- Attached a screen recording of the issue.
Assignee: nobody → rrosario
Iteration: --- → 59.4 - Jan 15
Priority: -- → P1
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Blocks: 1431263
I don't think this was actually fixed by https://github.com/mozilla/activity-stream/pull/3937 but the thing actually being fixed was bug 1403947.
Assignee: rrosario → nobody
No longer blocks: 1431263
Status: RESOLVED → REOPENED
Priority: P1 → P3
Resolution: FIXED → ---
See Also: → 1403947
Commits pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/8ce01447d61af678ef7cfd1d7f127c02453cbd4c
Fix Bug 1430132 - dont show hover/active/focus state during DnD

https://github.com/mozilla/activity-stream/commit/68627453a839d7a21db33ea1e108bd90a12d0ccf
Merge pull request #3944 from rlr/bug1430132/dnd-hover-button

Fix Bug 1430132 - dont show hover/active/focus state during DnD
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Assignee: nobody → rrosario
Iteration: 59.4 - Jan 15 → 60.1 - Jan 29
Blocks: 1431945
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
Firefox: 60.0a1, Build ID 20180126035135

I have verified that this issue is no longer reproducible on Windows 10 x64, Ubuntu 14.04 x64 and Mac 10.12 with the latest Nightly build (60.0a1) installed. Now the context menu button is no longer displayed when you move the Top Site to the left.
Status: RESOLVED → VERIFIED
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.