Closed Bug 1430500 Opened 5 years ago Closed 5 years ago

Hit MOZ_CRASH(accessing non-early pref consoleservice.logcat before late prefs are set)

Categories

(Firefox for Android Graveyard :: General, defect, P3)

All
Android
defect

Tracking

(firefox59 affected)

RESOLVED DUPLICATE of bug 1439406
Tracking Status
firefox59 --- affected

People

(Reporter: JanH, Unassigned)

References

Details

Might be responsible for some intermittent failures in e10s tests, like e.g. dom/ipc/tests/test_blob_sliced_from_parent_process.html (https://treeherder.mozilla.org/#/jobs?repo=try&revision=2f54757d437fcdaa82aee35b8d94dbdb84225262&selectedJob=156266897)

01-14 15:15:55.352  1200  1214 I Gecko   : : 'NS_SUCCEEDED(rv)', file /builds/worker/workspace/build/src/toolkit/xre/nsAppStartupNotifier.cpp, line 71
01-14 15:15:55.402  1200  1214 F MOZ_CRASH: Hit MOZ_CRASH(accessing non-early pref consoleservice.logcat before late prefs are set) at /builds/worker/workspace/build/src/modules/libpref/Preferences.cpp:790
01-14 15:16:00.042    38    38 D Zygote  : Process 1200 terminated by signal (11)
01-14 15:16:00.052   798  1197 I GeckoProcessManager: Binder died for tab
01-14 15:16:00.062   278   289 I ActivityManager: Process org.mozilla.fennec_aurora:tab (pid 1200) has died.
[triage] Don't see this in crash-stats; comment 0 indicates this may only occur in tests.
Priority: -- → P3
Given that we'll likely want to log everything right from the start if the pref is enabled, but on the other hand not log anything if it isn't (not sure how likely that actually is early during content process startup, but in principle the console can leak visited URLs, which I guess is one of the reasons why the pref is off on Release/Beta), I suppose the answer would be yes.
I'll dup this to bug 1430500. That bug is newer, but it has a patch, so makes sense to continue things there.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1439406
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.