Closed Bug 1439406 Opened 3 years ago Closed 3 years ago

MOZ_CRASH(accessing non-early pref consoleservice.logcat before late prefs are set)

Categories

(Core :: XPCOM, defect)

All
Android
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla60
Tracking Status
firefox60 --- fixed

People

(Reporter: jchen, Assigned: jchen)

References

Details

Attachments

(1 file)

I see this crash a lot when running GeckoView under e10s
Assignee: nobody → nchen
Status: NEW → ASSIGNED
Comment on attachment 8952251 [details]
Bug 1439406 - Add consoleservice.logcat as early pref;

https://reviewboard.mozilla.org/r/221500/#review227308

I think this change is fine, but this file has a giant "DO NOT ADD PREFS TO THIS LIST WITHOUT DOM PEER REVIEW" warning at the top, and I'm not a DOM peer, so I will defer to a DOM peer.

The good news is that I have a plan for getting rid of this list, in bug 1436911.
Attachment #8952251 - Flags: review?(n.nethercote)
Attachment #8952251 - Flags: review?(bkelly)
Duplicate of this bug: 1430500
Attachment #8952251 - Flags: review?(bkelly) → review?(continuation)
Comment on attachment 8952251 [details]
Bug 1439406 - Add consoleservice.logcat as early pref;

https://reviewboard.mozilla.org/r/221500/#review227320
Attachment #8952251 - Flags: review?(continuation) → review+
Pushed by xquan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/66b561299185
Add consoleservice.logcat as early pref; r=mccr8
https://hg.mozilla.org/mozilla-central/rev/66b561299185
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
You need to log in before you can comment on or make changes to this bug.