Closed Bug 1431064 Opened 2 years ago Closed 2 years ago

Crash in nsDisplayList::GetClippedBoundsWithRespectToASR const

Categories

(Core :: Web Painting, defect, P1, critical)

59 Branch
Unspecified
macOS
defect

Tracking

()

RESOLVED FIXED
mozilla59
Tracking Status
firefox-esr52 --- unaffected
firefox57 --- unaffected
firefox58 --- unaffected
firefox59 --- fixed

People

(Reporter: calixte, Assigned: mattwoodrow)

References

(Blocks 1 open bug)

Details

(Keywords: crash, regression, topcrash, Whiteboard: [clouseau])

Crash Data

This bug was filed from the Socorro interface and is
report bp-2a72ea1e-decd-411e-89b0-db79d0180117.
=============================================================

Top 10 frames of crashing thread:

0 XUL nsDisplayList::GetClippedBoundsWithRespectToASR const layout/painting/nsDisplayList.cpp:3151
1 XUL nsDisplayWrapList::UpdateBounds layout/painting/nsDisplayList.h:4827
2 XUL RetainedDisplayListBuilder::MergeDisplayLists layout/painting/RetainedDisplayListBuilder.cpp:504
3 XUL RetainedDisplayListBuilder::MergeDisplayLists layout/painting/RetainedDisplayListBuilder.cpp:501
4 XUL RetainedDisplayListBuilder::MergeDisplayLists layout/painting/RetainedDisplayListBuilder.cpp:501
5 XUL RetainedDisplayListBuilder::AttemptPartialUpdate layout/painting/RetainedDisplayListBuilder.cpp:945
6 XUL nsLayoutUtils::PaintFrame layout/base/nsLayoutUtils.cpp:3834
7 XUL mozilla::PresShell::Paint layout/base/PresShell.cpp:6485
8 XUL nsViewManager::ProcessPendingUpdatesPaint view/nsViewManager.cpp:480
9 XUL nsViewManager::ProcessPendingUpdatesForView view/nsViewManager.cpp:412

=============================================================

There are 55 crashes in nightly 59 with buildid 20180117100129. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1420737.

[1] https://hg.mozilla.org/mozilla-central/rev/ff731fad7630
Flags: needinfo?(matt.woodrow)
Crash Signature: [@ nsDisplayList::GetClippedBoundsWithRespectToASR const] → [@ nsDisplayList::GetClippedBoundsWithRespectToASR const] [@ nsDisplayList::GetClippedBoundsWithRespectToASR]
Duplicate of this bug: 1431083
The signature 'nsDisplayList::GetClippedBoundsWithRespectToASR const' is ranked #2 in content process for nightly 59.
Keywords: topcrash
STR for me open my facebook tab
I see this whenever opening a conversation on hangouts.google.com
Duplicate of this bug: 1431111
Assignee: nobody → matt.woodrow
Blocks: 1352499
Priority: -- → P1
I backed out bug 1420737 so the nightlies starting in less than an hour won't have this crash.

https://hg.mozilla.org/mozilla-central/rev/6fe09f2de63da649e9a8bbff701b445df7d75094
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(matt.woodrow)
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Duplicate of this bug: 1431290
You need to log in before you can comment on or make changes to this bug.