Closed Bug 1431704 Opened 2 years ago Closed 2 years ago

Devtools menu not showing while webrender enabled

Categories

(Core :: Graphics: WebRender, defect, P1)

Unspecified
macOS
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: safwan, Unassigned)

References

Details

Attachments

(2 files, 1 obsolete file)

# Enable Webrender in Firefox Nightly
# Open devtools

Actual Results:
You will see no menu in the devtools. Only blank space appear. but clicking on the blank space, the menu works.

Expected Results:
You should be able to see the menu of devtools
Nightly 59 x64 20180119103852 de_DE @ Debian Testing (KDE, Radeon RX480)
WFM.

Is this a regression for you; did it work in the past?
Could you please open about:support, click on the "Copy text to clipboard" button, paste it into a text file and upload it here (Attach File)? Thank you.
OS: Unspecified → Mac OS X
Version: unspecified → Trunk
Attached file about:support data (obsolete) —
(In reply to Jan Andre Ikenmeyer [:darkspirit] from comment #1)
> Nightly 59 x64 20180119103852 de_DE @ Debian Testing (KDE, Radeon RX480)
> WFM.
> 
> Is this a regression for you; did it work in the past?
> Could you please open about:support, click on the "Copy text to clipboard"
> button, paste it into a text file and upload it here (Attach File)? Thank
> you.

As far as I remember, I had webrender enabled in the past when its needed to toggle 3-4 settings. I can not be totally sure.
I have added the about:support
Thanks!

This bug was reported 7 hours ago, so this might correlate:

> Crash Reports for the Last 3 Days
> ---------------------------------
> 
> Report ID: bp-8042a6a9-9fb0-4d5d-bdc5-f593a0180119 WR+ [@ mozalloc_abort | abort | rayon_core::job::{{impl}}::execute<T> ]
> Submitted: 6 hours ago = bug 1431448
> 
> Report ID: bp-e985dca3-2222-4f1b-9280-21d640180119 WR+ [@ mozalloc_abort | abort | rayon_core::job::{{impl}}::execute<T> ]
> Submitted: 7 hours ago = bug 1431448
> 
> Report ID: bp-684ed923-604f-4f04-a04e-e1db40180119 WR+ [@ mozalloc_abort | abort | rayon_core::job::{{impl}}::execute<T> ]
> Submitted: 7 hours ago = bug 1431448
> 
> Report ID: bp-7122334a-0085-4cd9-9d8a-cfee30180119 WR+ [@ mozalloc_abort | abort | rayon_core::job::{{impl}}::execute<T> ]
> Submitted: 7 hours ago = bug 1431448
> 
> Report ID: bp-950b2a8d-12e2-42f5-ba6b-29cc20180118 WR+ [@ mozalloc_abort | abort | rayon_core::job::{{impl}}::execute<T> ]
> Submitted: 1 day ago = bug 1431448

Possibly offtopic:
> Report ID: bp-b32c4dc9-3314-4594-9bc8-f14cb0180117 WR+ [@ nsDisplayList::GetClippedBoundsWithRespectToASR const ]
> Submitted: 2 days ago
> 
> Report ID: bp-5d8ba05a-8dfb-4ab7-b17a-72fe50180117 WR+ [@ nsDisplayList::GetClippedBoundsWithRespectToASR const ]
> Submitted: 2 days ago
> 
> Report ID: bp-828d0e09-380b-45f1-b14c-53d7e0180117 WR+ [@ nsDisplayList::GetClippedBoundsWithRespectToASR const ]
> Submitted: 2 days ago
> 
> Report ID: bp-742b0181-f811-4368-9f15-c44bc0180117 WR+ [@ nsDisplayList::GetClippedBoundsWithRespectToASR const ]
> Submitted: 2 days ago
> 
> Report ID: bp-b86bbe84-526e-4dc1-9ca8-c7e0d0180117 WR+ [@ nsDisplayList::GetClippedBoundsWithRespectToASR const ]
> Submitted: 2 days ago
> 
> Report ID: bp-7d31124e-2fe9-45d1-a03c-165170180117 WR+ [@ nsDisplayList::GetClippedBoundsWithRespectToASR const ]
> Submitted: 2 days ago
> 
> Report ID: bp-6ec3c3d5-7fd8-430c-aa12-ceae90180117 WR+ [@ nsDisplayList::GetClippedBoundsWithRespectToASR const ]
> Submitted: 2 days ago
> 
> Report ID: bp-fb7a812c-e7a1-45cd-b17f-bc9e50180117 WR+ [@ nsDisplayList::GetClippedBoundsWithRespectToASR const ]
> Submitted: 2 days ago
> 
> Report ID: bp-7778d1f4-102a-4583-af66-86cf90180117 --> WR- <-- [@ nsDisplayList::GetClippedBoundsWithRespectToASR const ]
> Submitted: 2 days ago

I'm unsure if I should mark this as duplicate of bug 1431448, or just "Depends on: bug 1431448" for now?
(In reply to Jan Andre Ikenmeyer [:darkspirit] from comment #4)
> Thanks!
> 
> This bug was reported 7 hours ago, so this might correlate:
> 
> > Crash Reports for the Last 3 Days
> > ---------------------------------
> > 
> > Report ID: bp-8042a6a9-9fb0-4d5d-bdc5-f593a0180119 WR+ [@ mozalloc_abort | abort | rayon_core::job::{{impl}}::execute<T> ]
> > Submitted: 6 hours ago = bug 1431448
> > 
> > Report ID: bp-e985dca3-2222-4f1b-9280-21d640180119 WR+ [@ mozalloc_abort | abort | rayon_core::job::{{impl}}::execute<T> ]
> > Submitted: 7 hours ago = bug 1431448
> > 
> > Report ID: bp-684ed923-604f-4f04-a04e-e1db40180119 WR+ [@ mozalloc_abort | abort | rayon_core::job::{{impl}}::execute<T> ]
> > Submitted: 7 hours ago = bug 1431448
> > 
> > Report ID: bp-7122334a-0085-4cd9-9d8a-cfee30180119 WR+ [@ mozalloc_abort | abort | rayon_core::job::{{impl}}::execute<T> ]
> > Submitted: 7 hours ago = bug 1431448
> > 
> > Report ID: bp-950b2a8d-12e2-42f5-ba6b-29cc20180118 WR+ [@ mozalloc_abort | abort | rayon_core::job::{{impl}}::execute<T> ]
> > Submitted: 1 day ago = bug 1431448
> 
> Possibly offtopic:
> > Report ID: bp-b32c4dc9-3314-4594-9bc8-f14cb0180117 WR+ [@ nsDisplayList::GetClippedBoundsWithRespectToASR const ]
> > Submitted: 2 days ago
> > 
> > Report ID: bp-5d8ba05a-8dfb-4ab7-b17a-72fe50180117 WR+ [@ nsDisplayList::GetClippedBoundsWithRespectToASR const ]
> > Submitted: 2 days ago
> > 
> > Report ID: bp-828d0e09-380b-45f1-b14c-53d7e0180117 WR+ [@ nsDisplayList::GetClippedBoundsWithRespectToASR const ]
> > Submitted: 2 days ago
> > 
> > Report ID: bp-742b0181-f811-4368-9f15-c44bc0180117 WR+ [@ nsDisplayList::GetClippedBoundsWithRespectToASR const ]
> > Submitted: 2 days ago
> > 
> > Report ID: bp-b86bbe84-526e-4dc1-9ca8-c7e0d0180117 WR+ [@ nsDisplayList::GetClippedBoundsWithRespectToASR const ]
> > Submitted: 2 days ago
> > 
> > Report ID: bp-7d31124e-2fe9-45d1-a03c-165170180117 WR+ [@ nsDisplayList::GetClippedBoundsWithRespectToASR const ]
> > Submitted: 2 days ago
> > 
> > Report ID: bp-6ec3c3d5-7fd8-430c-aa12-ceae90180117 WR+ [@ nsDisplayList::GetClippedBoundsWithRespectToASR const ]
> > Submitted: 2 days ago
> > 
> > Report ID: bp-fb7a812c-e7a1-45cd-b17f-bc9e50180117 WR+ [@ nsDisplayList::GetClippedBoundsWithRespectToASR const ]
> > Submitted: 2 days ago
> > 
> > Report ID: bp-7778d1f4-102a-4583-af66-86cf90180117 --> WR- <-- [@ nsDisplayList::GetClippedBoundsWithRespectToASR const ]
> > Submitted: 2 days ago
> 
> I'm unsure if I should mark this as duplicate of bug 1431448, or just
> "Depends on: bug 1431448" for now?

I think its not duplicate. It maybe corelated with that bug. I have also filled the bug 1431711 which maybe related.
See Also: → 1431448
(In reply to Safwan Rahman (:safwan) from comment #2)
> Created attachment 8944001 [details]
> about:support data

This about:support indicates webrender is off.
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #6)
> (In reply to Safwan Rahman (:safwan) from comment #2)
> > Created attachment 8944001 [details]
> > about:support data
> 
> This about:support indicates webrender is off.

Sorry, I turned off the wenrender to do my work. I am uploading the file again after activating webrender
Attached file about:support data
Attachment #8944001 - Attachment is obsolete: true
It this still broken?
Flags: needinfo?(safwan.rahman15)
I can't reproduce this (although I don't think I ever could). No response from reporter either, so we don't have anything else to go on here. Closing as WFM.
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(safwan.rahman15)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.