Closed Bug 1431752 Opened 2 years ago Closed 2 years ago

Port Bug 1411579 "Open with" list is empty and and application chooser is empty" to SeaMonkey

Categories

(SeaMonkey :: OS Integration, defect, P5, blocker)

defect

Tracking

(seamonkey2.56 fixed)

RESOLVED FIXED
seamonkey2.56
Tracking Status
seamonkey2.56 --- fixed

People

(Reporter: frg, Assigned: frg)

References

Details

Attachments

(1 file, 1 obsolete file)

Linux build is busted. See Bug 1431548 for Thunderbird.

+++ This bug was initially created as a clone of Bug #1411579 +++

Since the application in flatpak does not have access to the list of applications on the host, there's currently no way how to get list of handler apps for specific mime type.
Attached patch port_bug1411579.diff (obsolete) — Splinter Review
Patch from Bill.
Aligned it more with current Fx code. IanN I think you should probably review it. I don't know much how to check this on Linux. Not sure if we shouldn't port Bug  Bug 1297686 too.
Attachment #8943971 - Attachment is obsolete: true
Attachment #8943994 - Flags: review?(iann_bugzilla)
Comment on attachment 8943994 [details] [diff] [review]
port_bug1411579_V2.diff

r=me
Attachment #8943994 - Flags: review?(iann_bugzilla) → review+
Duplicate of this bug: 1432082
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/eadd0577e853
Port bug 1411579 to suite: adjust nsIGIOService::GetAppForURIScheme() call. r=IanN
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
NI so I don't forget to file a followup bug
Flags: needinfo?(frgrahl)
Target Milestone: --- → Seamonkey2.56
Blocks: 1559255

Follow-up Bug 1559255 created

Clearing NI

Flags: needinfo?(frgrahl)
You need to log in before you can comment on or make changes to this bug.