Add section in prefs to turn off parts of Highlights

VERIFIED FIXED in Firefox 61

Status

()

enhancement
P2
normal
VERIFIED FIXED
Last year
Last year

People

(Reporter: Mardak, Assigned: Mardak)

Tracking

(Blocks 4 bugs)

Trunk
Firefox 61
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox60 wontfix, firefox61 verified)

Details

(Whiteboard: [strings landed])

Attachments

(3 attachments, 1 obsolete attachment)

Assignee

Description

Last year
From https://github.com/mozilla/activity-stream/issues/3155

At minimum the whole section can be turned off but the full feature is to be able to individually turn off bookmarks and visited sites.

https://mozilla.invisionapp.com/share/4CCZSU2BU#/screens/248174509_New_Tab_Prefs

image

Pref pane behavior:

    If the user unchecks both Bookmarks and Visited Sites, the Highlights section is also unchecked.
    If Highlights section is unchecked, the sub option box is disabled at 50% opacity not allowing clicks but maintains whatever the user has checked for Bookmarks and Visited Sites.
    If all sub options are unchecked and the user is turning on Highlights section, all options are now checked.

Highlight section behavior (from #3378 (comment)):

    If the user is excluding Bookmarks, all items should appear as Visited but context menu allows removing a bookmarked page. They keep the Visited type even when bookmarked and without shifting around cards, but the context menu will update to allow Remove Bookmark.
    If the user is excluding Visited Sites, only bookmarks should appear, and these show Bookmarked. If the user then Remove Bookmark from context menu, that card is dismissed immediately.
Assignee

Updated

Last year
Blocks: 1432586
Assignee

Comment 1

Last year
The strings for bookmarks and visited sites should already have been landed.
Whiteboard: [strings landed]
Assignee

Comment 2

Last year
Will be more needed when we add other data types (more than the current history + bookmarks, and the incoming pocket)
Iteration: --- → 61.1 - Mar 26
Priority: -- → P3
Assignee

Updated

Last year
Severity: normal → enhancement
Iteration: 61.1 - Mar 26 → ---
Assignee

Updated

Last year
Iteration: --- → 61.2 - Apr 9
Priority: P3 → P2
Duplicate of this bug: 1433233
Assignee: nobody → edilee
Iteration: 61.2 - Apr 9 → 61.3 - Apr 23
Assignee

Updated

Last year
Blocks: 1432589
Assignee

Comment 4

Last year
Looks like we're missing strings for including pocket in highlights.
Flags: needinfo?(abenson)
Whiteboard: [strings landed] → [strings needed]

Comment 5

Last year
Looks like an old InVision mock is linked above. Here's the updated version. https://mozilla.invisionapp.com/share/MFGXGZIG5JD#/280785532_Explainer

The string we'd need is "Pocket Saves".
Flags: needinfo?(abenson)
Assignee

Comment 6

Last year
With downloads in highlights maybe landing soon, I suppose we should have a checkbox for that too.. even though we only show a single download? "[✓] Downloads" ?
Flags: needinfo?(abenson)

Comment 7

Last year
Should say "[✓] Most Recent Download"
Flags: needinfo?(abenson)
Assignee

Comment 8

Last year
(In reply to Aaron Benson from comment #5)
> https://mozilla.invisionapp.com/share/MFGXGZIG5JD#/280785532_Explainer
The mock only has 3 options:
[✓] Visited Pages
[✓] Most Recent Download
[✓] Pocket Saves

Where should "[✓] Bookmarks" go? Also, just confirming that the previous design had "Visited Sites" but now it should be "Visited Pages"?
Flags: needinfo?(abenson)
Assignee

Comment 9

Last year
Posted image v1 screenshot (obsolete) —
I'll assume bookmarks come after visited for now.
Assignee

Comment 10

Last year
Posted image v1.1 screenshot
Attachment #8969159 - Attachment is obsolete: true

Comment 11

Last year
(In reply to Ed Lee :Mardak from comment #10)
> Created attachment 8969160 [details]
> v1.1 screenshot

This looks good to me .. updated the spec!
Flags: needinfo?(abenson)
Assignee

Comment 13

Last year
abenson/nchapman: We're trying to land this feature and strings today for localizers to have time to translate for 61. In particular, is there a preferred wording for "Pocket Saves" and can it be translated as just "Pocket Saved Items" (and should we just use that for en-US?). See attachment 8969160 [details] for a screenshot.

The pocket website doesn't seem to use the term "Saves" for referring to the saved items in "My List". And "Saves" I would guess is tricky to translate as "Save" happens to be the same word for the verb action and the noun describing the result in English.

If there isn't an official term for other languages, we'll just have a note for localizers describing the intent of the string, e.g.,

"Pocket" is a brand name. "Saves" is a plural noun referring to the result of multiple "Save" actions; "Saved Items" can be used instead. Preferably, "Saves" matches up with the primary "Save to Pocket" action for saving a page.
Flags: needinfo?(nchapman)
Flags: needinfo?(abenson)
Commit pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/8657d4185a031f3bfe925ad767e6653b221b320b
feat(highlights): Add include* prefs to let about:preferences control what gets shown (#4111)

Fix Bug 1432595 - Add section in prefs to turn off parts of Highlights

Updated

Last year
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Assignee

Updated

Last year
Blocks: 1455682
Assignee

Updated

Last year
Blocks: 1455684

Comment 15

Last year
Hi Ed,

I had a chat with the rest of the Pocket team, and we'd like to use "Pages Saved to Pocket". It clears up some of the noun/verb problems and aligns with us using "pages" in various contexts instead of items.

Thanks!

Nick
Flags: needinfo?(nchapman)
Flags: needinfo?(abenson)
Commit pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/a772240e93f97e05886ca7b3d2e7ce58deb7ad0d
fix(strings): Update pocket highlight option to "Pages Saved to Pocket" (#4114)

Followup Bug 1432595 - Add section in prefs to turn off parts of Highlights
Assignee

Updated

Last year
Blocks: 1455216

Comment 18

Last year
(In reply to Nick Chapman from comment #15)
> Hi Ed,
> 
> I had a chat with the rest of the Pocket team, and we'd like to use "Pages
> Saved to Pocket". It clears up some of the noun/verb problems and aligns
> with us using "pages" in various contexts instead of items.
> 
> Thanks!
> 
> Nick

Thanks Nick! Spec updated here: https://mozilla.invisionapp.com/share/MFGXGZIG5JD#/screens/280785532_Explainer
Assignee

Comment 19

Last year
https://hg.mozilla.org/mozilla-central/rev/5d2486077e4b
Target Milestone: --- → Firefox 61
Assignee

Comment 20

Last year
Strings landed for localization in https://github.com/mozilla/activity-stream-l10n/pull/15
Whiteboard: [strings needed] → [strings landed]
Build ID 	20180422223305
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

I have verified that the issue is no longer reproducible on the latest Nightly build on Windows 10 x64, Mac 10.13.3 and Arch Linux x64. All types of Highlight cards can now be individually hidden as seen in the spec from comment 18.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.