Closed Bug 1432773 Opened 2 years ago Closed 2 years ago

Intermittent /webdriver/tests/actions/mouse.py | mouse.py::test_click_element_center

Categories

(Testing :: geckodriver, defect, P5)

Version 3
All
Linux
defect

Tracking

(firefox59 fixed, firefox60 fixed)

RESOLVED FIXED
mozilla60
Tracking Status
firefox59 --- fixed
firefox60 --- fixed

People

(Reporter: ebalazs_, Assigned: maja_zf)

References

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell fixed:other])

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1421878 +++

[task 2017-11-29T21:07:18.140Z] 21:07:18     INFO - TEST-PASS | /webdriver/tests/actions/mouse.py | mouse.py::test_click_at_coordinates 
2262
[task 2017-11-29T21:07:18.140Z] 21:07:18     INFO - TEST-PASS | /webdriver/tests/actions/mouse.py | mouse.py::test_context_menu_at_coordinates 
2263
[task 2017-11-29T21:07:18.140Z] 21:07:18     INFO - TEST-UNEXPECTED-FAIL | /webdriver/tests/actions/mouse.py | mouse.py::test_click_element_center 
2264
[task 2017-11-29T21:07:18.140Z] 21:07:18     INFO - session = <webdriver.client.Session object at 0x7f7e4bd73550>
2265
[task 2017-11-29T21:07:18.141Z] 21:07:18     INFO - test_actions_page = None
2266
[task 2017-11-29T21:07:18.141Z] 21:07:18     INFO - mouse_chain = <webdriver.client.ActionSequence object at 0x7f7e4bd73a50>
2267
[task 2017-11-29T21:07:18.141Z] 21:07:18     INFO - 
2268
[task 2017-11-29T21:07:18.141Z] 21:07:18     INFO -     def test_click_element_center(session, test_actions_page, mouse_chain):
2269
[task 2017-11-29T21:07:18.142Z] 21:07:18     INFO -         outer = session.find.css("#outer", all=False)
2270
[task 2017-11-29T21:07:18.142Z] 21:07:18     INFO -         center = get_center(outer.rect)
2271
[task 2017-11-29T21:07:18.142Z] 21:07:18     INFO -         mouse_chain.click(element=outer).perform()
2272
[task 2017-11-29T21:07:18.142Z] 21:07:18     INFO -         events = get_events(session)
2273
[task 2017-11-29T21:07:18.142Z] 21:07:18     INFO - >       assert len(events) == 4
2274
[task 2017-11-29T21:07:18.143Z] 21:07:18     INFO - E       assert 5 == 4
2275
[task 2017-11-29T21:07:18.143Z] 21:07:18     INFO - E        +  where 5 = len([{'altKey': False, 'button': 0, 'buttons': 0, 'ctrlKey': False, ...}, {'altKey': False, 'button': 0, 'buttons': 1, 'ct...'button': 0, 'buttons': 0, 'ctrlKey': False, ...}, {'altKey': False, 'button': 0, 'buttons': 0, 'ctrlKey': False, ...}])
Comment on attachment 8945183 [details]
Bug 1432773 - listen for unload in capture phase to reset click count;

https://reviewboard.mozilla.org/r/215424/#review221188

::: testing/marionette/listener.js:56
(Diff revision 1)
>  
>  // Listen for click event to indicate one click has happened, so actions
>  // code can send dblclick event
>  addEventListener("click", event.DoubleClickTracker.setClick);
>  addEventListener("dblclick", event.DoubleClickTracker.resetClick);
> -addEventListener("unload", event.DoubleClickTracker.resetClick);
> +addEventListener("unload", event.DoubleClickTracker.resetClick, true);

Not directly related to this change, but should the other two event listeners also operating in the captureing phase?
Attachment #8945183 - Flags: review?(hskupin) → review+
Comment on attachment 8945183 [details]
Bug 1432773 - listen for unload in capture phase to reset click count;

https://reviewboard.mozilla.org/r/215424/#review221188

> Not directly related to this change, but should the other two event listeners also operating in the captureing phase?

In the case of click and dblclick, capture versus bubble shouldn't make a difference, and that's what I confirmed in my testing as well.
Comment on attachment 8945183 [details]
Bug 1432773 - listen for unload in capture phase to reset click count;

https://reviewboard.mozilla.org/r/215424/#review221188

> In the case of click and dblclick, capture versus bubble shouldn't make a difference, and that's what I confirmed in my testing as well.

Also when `preventDefault` is used by content? If all that works, lets get it in! Thanks.
Comment on attachment 8945183 [details]
Bug 1432773 - listen for unload in capture phase to reset click count;

https://reviewboard.mozilla.org/r/215424/#review221188

> Also when `preventDefault` is used by content? If all that works, lets get it in! Thanks.

You mean `stopPropagation`? That could break things. I'll investigate and file a separate bug if needed. For now I just want to land this to fix the intermittent.
Pushed by mjzffr@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/c0b051e8b500
listen for unload in capture phase to reset click count; r=whimboo
Assignee: nobody → mjzffr
Status: NEW → ASSIGNED
https://hg.mozilla.org/mozilla-central/rev/c0b051e8b500
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
We might also need it for 59. Lets wait over the weekend how it works and then we can request an uplift.
Since Friday no more test failures. Please lets uplift to beta.
Whiteboard: [stockwell unknown] → [stockwell unknown][checkin-needed-beta]
Whiteboard: [stockwell unknown][checkin-needed-beta] → [stockwell fixed:other][checkin-needed-beta]
https://hg.mozilla.org/releases/mozilla-beta/rev/d791950b5abd
Whiteboard: [stockwell fixed:other][checkin-needed-beta] → [stockwell fixed:other]
You need to log in before you can comment on or make changes to this bug.