Closed Bug 1433037 Opened 2 years ago Closed Last year

taskbar preview's favicon appears blank

Categories

(Core :: Widget: Win32, defect, P3)

59 Branch
x86
Windows 10
defect

Tracking

()

VERIFIED FIXED
mozilla61
Tracking Status
firefox-esr52 --- unaffected
firefox59 --- wontfix
firefox60 --- verified
firefox61 --- verified

People

(Reporter: ershiwo, Assigned: baku)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached image 2018-01-25_141831.png
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20180122192913

Steps to reproduce:

Enable "Show tab previews in the Windows taskbar" feature, and move your cursor to taskbar.


Actual results:

All favicons of multitabs appear blank, not only built-in pages.
Component: Untriaged → Widget: Win32
OS: Unspecified → Windows 10
Product: Firefox → Core
Hardware: Unspecified → x86
I was able to reproduce this bug:

1) Start Firefox and open two tabs (https://www.google.com and https://www.mozilla.org for example)
2) Open about:preferences and enable the following option: "Show tab previews in the Windows taskbar"
3) Hover the mouse over the Firefox icon in the taskbar.

Expected result: The favicons are shown on the upper left corner of the tab previews.
Actual result: The default icon is displayed on the upper left corner of the previews.

The problem can be reproduced on the latest available Nightly: 20180127100319

Latest nightly WITHOUT this bug is: 20171127100433
First nightly in which this bug appeared is: 20171127220446
Status: UNCONFIRMED → NEW
Ever confirmed: true
What did you use the get that regression range? mozregression will automatically output a link that includes the changesets between those two builds which would be very helpful.
(In reply to Timothy Nikkel (:tnikkel) from comment #2)
> What did you use the get that regression range? mozregression will
> automatically output a link that includes the changesets between those two
> builds which would be very helpful.

OK, I will have a try.
(In reply to ershiwo from comment #3)
> (In reply to Timothy Nikkel (:tnikkel) from comment #2)
> > What did you use the get that regression range? mozregression will
> > automatically output a link that includes the changesets between those two
> > builds which would be very helpful.
> 
> OK, I will have a try.

I have run the mozregression with new profiles and got the changesets between ae8dbca85bfec5b3e53e578b5c65b0effbeccdc2 and 16dfec69b8b0e4c70f3438db5043dcd0b7bc97f0.

The last good beta build: https://hg.mozilla.org/releases/mozilla-beta/pushloghtml?fromchange=ae8dbca85bfec5b3e53e578b5c65b0effbeccdc2&tochange=0c5a115449a3e470307b83d92531c84c23382951
The bad beta build: https://hg.mozilla.org/releases/mozilla-beta/pushloghtml?fromchange=ae8dbca85bfec5b3e53e578b5c65b0effbeccdc2&tochange=16dfec69b8b0e4c70f3438db5043dcd0b7bc97f0

Any other information that I could provide? I have never use mozregression before.
(In reply to ershiwo from comment #4)
> (In reply to ershiwo from comment #3)
> > (In reply to Timothy Nikkel (:tnikkel) from comment #2)
> > > What did you use the get that regression range? mozregression will
> > > automatically output a link that includes the changesets between those two
> > > builds which would be very helpful.
> > 
> > OK, I will have a try.
> 
> I have run the mozregression with new profiles and got the changesets
> between ae8dbca85bfec5b3e53e578b5c65b0effbeccdc2 and
> 16dfec69b8b0e4c70f3438db5043dcd0b7bc97f0.
> 
> The last good beta build:
> https://hg.mozilla.org/releases/mozilla-beta/
> pushloghtml?fromchange=ae8dbca85bfec5b3e53e578b5c65b0effbeccdc2&tochange=0c5a
> 115449a3e470307b83d92531c84c23382951
> The bad beta build:
> https://hg.mozilla.org/releases/mozilla-beta/
> pushloghtml?fromchange=ae8dbca85bfec5b3e53e578b5c65b0effbeccdc2&tochange=16df
> ec69b8b0e4c70f3438db5043dcd0b7bc97f0
> 
> Any other information that I could provide? I have never use mozregression
> before.

Thanks for doing that!

I'm a little confused how you got a regression window on the mozilla-beta tree. Usually mozregression will work on mozilla-central (what nightly is built from). That would allow a much smaller regression window with less changes in it. I scanned the list of changes in your link and nothing stood out at me that might cause this. Is there any chance you could try again on mozilla-central?
(In reply to Timothy Nikkel (:tnikkel) from comment #5)
> (In reply to ershiwo from comment #4)
> > (In reply to ershiwo from comment #3)
> > > (In reply to Timothy Nikkel (:tnikkel) from comment #2)
> 
> Thanks for doing that!
> 
> I'm a little confused how you got a regression window on the mozilla-beta
> tree. Usually mozregression will work on mozilla-central (what nightly is
> built from). That would allow a much smaller regression window with less
> changes in it. I scanned the list of changes in your link and nothing stood
> out at me that might cause this. Is there any chance you could try again on
> mozilla-central?

I have run another test on mozregression:
The last good build: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c0245a5ba4ba74b16c24771dae0e50fe22443898&tochange=e60f002f07d0d40843758d40557acfc3ac6c51f3
The first bad build: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=ada1b4b1951bbe29bae0f0259c17adff1f31de7e&tochange=e60f002f07d0d40843758d40557acfc3ac6c51f3

Hopes they will help you to find where's the problem.
Thank you.
Blocks: 1420223
Priority: -- → P3
Possibly same as https://bugzilla.mozilla.org/show_bug.cgi?id=1403620

I can't tell whether it's the same regression range.
https://hg.mozilla.org/mozilla-central/rev/e60f002f07d0#l1.33
>+      imgTools.decodeImage(inputStream, channel.contentType, decodeCallback,

You could see "imgTools.decodeImage is not a function" if you don't suppress exception.
@:baku
Your patvh seems to cause the regression, Can you look into this?
Flags: needinfo?(amarchesini)
Attached patch image.patchSplinter Review
Assignee: nobody → amarchesini
Flags: needinfo?(amarchesini)
Attachment #8962355 - Flags: review?(aosmond)
Attachment #8962355 - Flags: review?(aosmond) → review+
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e94fdbab0e4a
WindowsPreviewPerTab should use decodeImageAsync, r=aosmond
https://hg.mozilla.org/mozilla-central/rev/e94fdbab0e4a
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
Please request beta uplift when you're comfortable doing so.
Flags: needinfo?(amarchesini)
Comment on attachment 8962355 [details] [diff] [review]
image.patch

Approval Request Comment
[Feature/Bug causing the regression]:Bug 1420223
[User impact if declined]: tab preview is broken on windows
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]:  STR is in comments
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: low
[Why is the change risky/not risky?]: in bug 1420223 I renamed decodeImage to decodeImageAsync but I forgot this call.
[String changes made/needed]: none
Flags: needinfo?(amarchesini)
Attachment #8962355 - Flags: approval-mozilla-beta?
Comment on attachment 8962355 [details] [diff] [review]
image.patch

Simple fix for broken Windows tab previews. Approved for 60.0b8.
Attachment #8962355 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
Build ID: 20180329154119
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0

Verified as fixed on Firefox Nightly 61.0a1 and Firefox 60.0b8 on Windows 10 x 64, Windows 7 x32.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
This problem returned on Firefox 63 b4.
https://i.loli.net/2018/09/09/5b949ed4ebb65.png
Version: 59 Branch → 63 Branch
(In reply to ershiwo from comment #19)
> This problem returned on Firefox 63 b4.
> https://i.loli.net/2018/09/09/5b949ed4ebb65.png

Please file a new bug for this.
Version: 63 Branch → 59 Branch
Duplicate of this bug: 1448773
You need to log in before you can comment on or make changes to this bug.