[MATE] Nightly on Linux: Browser window shrinks when toggling "Title Bar" setting on the "Customize" page

REOPENED
Assigned to

Status

()

defect
REOPENED
a year ago
8 months ago

People

(Reporter: dandromb, Assigned: stransky)

Tracking

(Blocks 1 bug, {nightly-community})

60 Branch
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox58 unaffected, firefox59 unaffected, firefox60 affected)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180126220105

Steps to reproduce:

- Click hamburger menu

- Click "Customize..."

- On Customize screen, click checkbox next to the words "Title Bar"


Actual results:

- Clicking to initially un-check the checkbox turns on Client-Side Decorations, ("CSD") as expected. (So far so good.)

- Clicking again to check the checkbox turns off CSD, as expected... *BUT* also shrinks the browser window by 10 pixels or so horizontally and vertically; Window gets narrower and shorter.

- Optional: Repeat many times, and your browser window will get really tiny.


Expected results:

The browser window, other than the title bar itself, should ideally not grow larger or smaller when toggling this checkbox.
Alternate steps to reproduce:

- Have CSD enabled ("Title Bar" unchecked)

- Quit or close Firefox Nightly

- Start Firefox Nightly again

Result:

- Browser window is a little smaller each time you launch Nightly with CSD enabled.
I would also add the following behavior on my Ubuntu 16.04 x64:

a. STR from comments 0 function correctly for me, until you maximize the window with CSD unchecked, in which case checking/unchecking the title bar will only have a refresh like effect on the browser window but no title bar, resizing the window or restarting leading to Actual Result from comment 0 (shrinked window).
Blocks: gtktitlebar
Component: Untriaged → Widget: Gtk
Product: Firefox → Core
I cannot reproduce exactly the same behaviour with "Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0 ID:20180219220041", however the window is resizing when toggling the preference, and even moving to the center of the screen, when not maximized.
(Assignee)

Updated

a year ago
Assignee: nobody → stransky
(Assignee)

Comment 4

a year ago
I'm unable to reproduce the size shrink, Fedora 27 / gnome-shell. I tried both system and client modes (MOZ_GTK_TITLEBAR_DECORATION=system and MOZ_GTK_TITLEBAR_DECORATION=client).

The flickering/window resize is here because we need to recreate the toplevel window and reparent Firefox content window. We can't fix that.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
I can still reproduce on Linux Mint 18.3 (MATE edition, if that matters.)

This could be specific to a DE/Window Manager, or (unlikely:) Wayland vs. X.org

(Also: Are you sure you followed the Steps to Reproduce 100%? The shrink is very subtle, it's only apparent after it happens a few times in a row, by which time you lose tens or hundreds of pixels on each side of the window.)
Just tested on Ubuntu Bionic development LiveCD image (Bionic uses the Gnome desktop):
 (http://cdimage.ubuntu.com/daily-live/current/bionic-desktop-amd64.iso)

Okay, so this appears to be *not* reproducible on Gnome, whether on Fedora or Ubuntu.

Still reproducible on MATE, possibly other DEs.

(Ubuntu Bionic uses Xorg, Fedora uses Wayland, and both work fine, so this appears not to have anything to do with Wayland vs. Xorg.)
(Assignee)

Comment 7

a year ago
Okay, thanks.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: WORKSFORME → ---
Summary: Nightly on Linux: Browser window shrinks when toggling "Title Bar" setting on the "Customize" page → [MATE] Nightly on Linux: Browser window shrinks when toggling "Title Bar" setting on the "Customize" page
Exhibits cumulative shrinking (when following the STR):

Linux Mint 18.3 with Mate
Linux Mint 18.3 with XFCE

--

Does not exhibit cumulative shrinking:

Linux Mint 18.3 with Cinnamon
Fedora 27 with Cinnamon
Fedora 27 with KDE
Fedora 27 with LXDE
Fedora 27 with LXQt
Fedora 27 with MATE & Compiz
Fedora 27 with XFCE
Kubuntu 17.10 with KDE
Ubuntu Mate 17.10 with MATE
Xubuntu 17.10 with XFCE

---

(I hope I didn't make any mistakes when compiling these results, but it looks like it only happens on Linux Mint (MATE or XFCE), as opposed to on Ubuntu or Fedora, although I didn't test Arch, Debian, or anything else not explicitly mentioned in this list. This took a long time and was tedious, so I might have made a mistake somewhere in there.)
By the way I can also reproduce on Linux Mint Debian Edition 2 "Betsy", with MATE desktop environment.
(Assignee)

Updated

a year ago
Duplicate of this bug: 1449228
(Assignee)

Comment 11

a year ago
Bug 1449166 may be related here.
See Also: → 1449166
(Assignee)

Comment 12

8 months ago
The XFCE bug should be fixed now by https://bugzilla.xfce.org/show_bug.cgi?id=14511
You need to log in before you can comment on or make changes to this bug.