Plug-in Finder Service is not really needed

VERIFIED DUPLICATE of bug 56106

Status

()

P3
normal
VERIFIED DUPLICATE of bug 56106
17 years ago
17 years ago

People

(Reporter: jofin, Assigned: rubydoo123)

Tracking

Trunk
Future
x86
Windows ME
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PL Mgr], URL)

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.0.0+) Gecko/20020508
BuildID:    20020508

If I open this webpage the plug-in finder tries to find a plug-in for
mimetype=audio/midi without success. 
There is no need in having this plug-in and I would be very glad if I could view
the website without being automatically redirected to plug-in finder website.
Although you don´t need to have the plug-in, there is no way to view the website. 
I really would like this to be changed.

Reproducible: Always
Steps to Reproduce:
1. Open a website with an uninstalled plug-in.


Actual Results:  redirection to
http://cgi.netscape.com/cgi-bin/plug-in_finder.cgi?mimetype=...

Expected Results:  nothing
When I open this site, I do not get redirected and there is no plugin dialog....
(and no, I have no MIDI plugin).

Do you get redirected automatically, or do you get a dialog that offers "OK" and
"Cancel" options?
(Reporter)

Comment 2

17 years ago
I am able to view the page for about one second. After that it redirects to
Netscape plug-in finder without any dialog boxes.
By the way: The website I meant is http://www.tv-quoten.de/index2.html.
I found an other website with the same behaviour:
http://www.miditrax.com
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

17 years ago
check ur pref under edit|prefs|navigator|helper app. uncheck it if u don't want 
to use it.
(Reporter)

Comment 4

17 years ago
>>check ur pref under edit|prefs|navigator|helper app. uncheck it if u don't want 
>>to use it.

I´m very sorry but this doesn´t change anything.

Comment 5

17 years ago
well, then make changes to quicktime and let it handle this mime type..u will 
need it anyway? 
Er, what does QuickTime have to do with this?

Reporter, if you uncheck the "Always use PFS" option and restart mozilla, does
this problem go away?  If not, then the option needs to be fixed to work.  If
the option _does_ work but needs a restart, our wording should say that.

Comment 7

17 years ago
PFS will be invoked in this case all the time..no matter what since the web 
author has not specified any "pluginspage" or "pluginurl" attribute.
code looks like this:

<EMBED SRC=" http://www.tv-quoten.de/Freunde_fuers_Leben.mid" HEIGHT=2 WIDTH=2 
AUTOSTART=TRUE HIDDEN=TRUE LOOP=TRUE>


 PFS logic is supposed to take over in such a case even if the check box is 
selected or not. Peter, can u pls confirm this? 
 
I tried this test, it took me here : 
http://cgi.netscape.com/cgi-bin/plug-in_finder.cgi?mimetype=audio/mid

which seems correct

Comment 8

17 years ago
Boris: by quicktime , I meant...to not see this in the first place (to not let 
PFS take over), let some plugin already handle the '.mid'extension ;). why be 
left out ?

Comment 9

17 years ago
and,btw, PFS does not need a restart, I confirmed. Closing the Prefs dialog 
sets/resets it. wfm ?
So.. let me get this straight.

Loading that page, _by_design_ will immediately take you to a different page? 
And not allow you to view the page you actually want?  With no way to disable
it?

As for why not quicktime... how about "I don't want my computer playing sounds
at me from web pages"?  That's not being left out, that's keeping my sanity.
(Reporter)

Comment 11

17 years ago
I think the user shouldn´t be forced to install a plug-in when it´s not really
needed to view the site. I really don´t like programs that don´t let me choose
wether I want to install a programm or not.
(Assignee)

Comment 12

17 years ago
The redirect to the PFS is by design if the web author does not include the
appropriate information. If you decide you do not want to download the plug-in,
just hit the back button and you will be returned to the page. Once you return
to the page, you should not be redirected again. If you are, then that is a bug.

Not viewing or opting to not view the plug-in will be part of the Plug-in
Manager. The user will have the ability to select "Do not display." Other
viewing capabilites will also be present.

Comment 13

17 years ago
> Loading that page, _by_design_ will immediately take you to a different page? 
And not allow you to view the page you actually want?  With no way to disable
it?

Firstly, the page that loads asking user to downlad plugin is a new window and 
not the same browser window. SO the user can get away with it by closing that 
window. Now..I amnot justifying that this is correct..but to solve this issue 
and to maintain ur sanity:)...the bug to implement Plugins Manager might take 
care of these issues (bug 19118).marking this wfm.. pls reopen with a 
justification, Thx!
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 14

17 years ago
To #12:
If I hit the back button I AM redirected again.

To #13:
The plug-in site DOES open in the same window.

So there is no way to view the original website without installing the plug-in.

Comment 15

17 years ago
how about Edit|Prefs|Advanced|Scripts & Widnows

Check the first selection and tell me what happens? Mine was ON by defauly..I 
never set it.

Status: RESOLVED → VERIFIED
(Reporter)

Comment 16

17 years ago
Edit|Prefs|Advanced|Scripts & Widnows
Checking "Open unrequested windows" doesn´t change anything.
(Reporter)

Comment 17

17 years ago
Edit|Prefs|Advanced|Scripts & Widnows
Checking "Open link in new window" WORKS as workaround but each visit on the
website will open new plug-in-windows.
Aha.  See bug 130337 -- this is very similar...

Reopening and marking dependent; this bug could also be fixed by using
window.open() in the PFS instead of redirecting to a target="_new/_blank" as we
seem to do.
Status: VERIFIED → REOPENED
Depends on: 130337
Resolution: WORKSFORME → ---

Comment 19

17 years ago
Created attachment 83113 [details]
test case

silent redirection only if HIDDEN=TRUE

Comment 20

17 years ago
Created attachment 83114 [details]
test case w/o HIDDEN=TRUE

Comment 21

17 years ago
for once, I felt that this might be an issue...but was lazy to test it out. Thx, 
serge !!

Comment 22

17 years ago
Created attachment 83118 [details]
test case WIDTH & HEIGHT too small

WIDTH & HEIGHT too small (no pazzle image)
there is no way to involve PFS.
(Assignee)

Updated

17 years ago
Priority: -- → P3
Whiteboard: [PL Mgr]
Target Milestone: --- → Future
(Assignee)

Comment 23

17 years ago
The plug-ins triage team (av, beppe, peterl, serge and shrir) have reviewed this
issue and have made the following determination:

This will be resolved through bug 56106

*** This bug has been marked as a duplicate of 56106 ***
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 24

17 years ago
mass duplicate verifications . For filtering purposes, pls use keywd
"massdupverification"

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.