Massive Xpcshell and Mozmill test failure on 2018-02-01

RESOLVED FIXED in Thunderbird 60.0

Status

enhancement
RESOLVED FIXED
Last year
Last year

People

(Reporter: jorgk, Assigned: jorgk)

Tracking

unspecified
Thunderbird 60.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Assignee

Description

Last year
Many failing tests and WaltS48 reports on IRC:

Every pane is blank and chat icon disabled. Couldn't open the Error Console.
Folder, Thread, and Message panes are empty, the Chat icon is disabled.

@WaltS48, this is what you reported, we'll look into it.
Assignee

Comment 1

Last year
M-C last good: 17ade9f88b6ed2232be51bc02c6860562c
M-C first bad: 5201997e7e01500176ce7d6e790593468f
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=17ade9f88b6ed2232be51bc02c6860562c&tochange=5201997e7e01500176ce7d6e790593468f

Looking at a log
https://archive.mozilla.org/pub/thunderbird/nightly/2018/02/2018-02-01-03-02-01-comm-central/comm-central_win7_ix_test-mozmill-bm110-tests1-windows-build171.txt.gz
I see heaps of
  Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getIntPref]
So that would suggest that the bustage comes from bug 1423840.

There are also quite a few of
  TypeError: mailWindow.gFolderDisplay is null

I'll try a local build first.
Back-out of bug 1423840 fixes the main window.
Assignee

Comment 3

Last year
One small syntax error in the pref file caused this havoc. Spotted by Aceman!
Assignee: nobody → jorgk
Status: NEW → ASSIGNED

Comment 4

Last year
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/255415033526
fix invalid pref syntax (spotted by aceman). rs=bustage-fix
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED

Updated

Last year
Attachment #8947561 - Flags: review+
Assignee

Updated

Last year
Target Milestone: --- → Thunderbird 60.0
Duplicate of this bug: 1435182

Comment 6

Last year
Hi everyone. My thunderbird daily is stuck in that state. About allows me to "Restart to update thunderbird" but it doesn't update it, and restart in the exact same state (with the button to update still there). Should I remove it and manually install the last daily build or is there a way I can update?
Assignee

Comment 7

Last year
Please uninstall the broken version manually and then install today's build (compiling now, assuming there won't be a build failure) or revert to the previous day, 2018-01-31 which should then update to today's build.
You need to log in before you can comment on or make changes to this bug.