Closed Bug 1435129 Opened 3 years ago Closed 3 years ago

regression: tab loading animations are broken

Categories

(Core :: Graphics: WebRender, defect, P1)

x86_64
All
defect

Tracking

()

RESOLVED DUPLICATE of bug 1435143
Tracking Status
firefox-esr52 --- unaffected
firefox58 --- unaffected
firefox59 --- unaffected
firefox60 --- disabled

People

(Reporter: jan, Assigned: gw)

References

Details

(Keywords: nightly-community, regression)

Attachments

(1 file)

(offtopic: I noticed this bug while checking bug 1347184 comment 46.)

The loading icon got microscopic / cut off / invisible.
(Only the loading icon of the second tab is relevant. You don't need to do anything.)

mozregression --good 2018-01-31 --bad 2018-02-01 --pref gfx.webrender.all:true startup.homepage_welcome_url:"about:addons|https://addons.mozilla.org/en-US/firefox/addon/quantum-lights-dynamic/"
> 7:40.51 INFO: Last good revision: 924b8c32b9a879e61d01404b2222ca68d3872fec
> 7:40.51 INFO: First bad revision: 3940b5d8f13529b17acfba25fa8e1d1d179628d0
> 7:40.51 INFO: Pushlog:
> https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=924b8c32b9a879e61d01404b2222ca68d3872fec&tochange=3940b5d8f13529b17acfba25fa8e1d1d179628d0

> 3940b5d8f135	Martin Roinson — Bug 1434288 - Update gecko for API changes in WR PR 2315. r=kats
> e99f6587c86e	Kartikaya Gupta — Bug 1434288 - Update webrender to commit e772c3cb8ea0a35e6477e9dc8dd2144e2de87b56. r=jrmuizel

-----

> WR @ b6e69a8efbcd8dc3e0c0a8a9925e6a9355635de3
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=9ea0e50f426552229ab5746ed3f5ab1c9ebf0561
mozregression --repo try --launch 9ea0e50f426552229ab5746ed3f5ab1c9ebf0561 --pref gfx.webrender.all:true startup.homepage_welcome_url:"about:addons|https://addons.mozilla.org/en-US/firefox/addon/quantum-lights-dynamic/"
-> good

> WR @ 87c6a6ba7e75d8ed0b2ddeeb5fa4e363482f7f86
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=7801945b00e7eac75e8bdf9d64869a9c284599de
mozregression --repo try --launch 7801945b00e7eac75e8bdf9d64869a9c284599de --pref gfx.webrender.all:true startup.homepage_welcome_url:"about:addons|https://addons.mozilla.org/en-US/firefox/addon/quantum-lights-dynamic/"
-> good

> WR @ e772c3cb8ea0a35e6477e9dc8dd2144e2de87b56, with the fixes
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=62ab4844535a8ae2194ee6b7e43c1f9f05bb1511
mozregression --repo try --launch 62ab4844535a8ae2194ee6b7e43c1f9f05bb1511 --pref gfx.webrender.all:true startup.homepage_welcome_url:"about:addons|https://addons.mozilla.org/en-US/firefox/addon/quantum-lights-dynamic/"
-> bad

https://github.com/servo/webrender/compare/87c6a6ba7e75d8ed0b2ddeeb5fa4e363482f7f86...e772c3cb8ea0a35e6477e9dc8dd2144e2de87b56
Same on Windows 10.
OS: Linux → All
Summary: regression: tab loading icon is broken → regression: tab loading animations are broken
Assignee: nobody → gwatson
Priority: -- → P1
I haven't confirmed, but I suspect this to be the same bug as https://bugzilla.mozilla.org/show_bug.cgi?id=1435143 (I've added some more details in that bug).
See Also: → 1435143
Duplicate of this bug: 1436288
Fixed in the try build from bug 1435143 comment 7.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
See Also: 1435143
Duplicate of bug: 1435143
This being fixed with a PR - is there a Gecko side reftest that we can add that catches this problem?
You need to log in before you can comment on or make changes to this bug.