Closed Bug 1436449 Opened 6 years ago Closed 6 years ago

Rename item_id to pocket_id for clearer way to identify saved Pocket items in NewTabUtils

Categories

(Firefox :: New Tab Page, enhancement, P1)

57 Branch
enhancement

Tracking

()

RESOLVED FIXED
Firefox 60
Iteration:
60.2 - Feb 12
Tracking Status
firefox60 --- fixed

People

(Reporter: ursula, Assigned: ursula)

References

Details

Attachments

(1 file)

+ while I'm here also fixing some nits that I realized while doing Bug 1432657
Severity: normal → enhancement
Comment on attachment 8949153 [details]
Bug 1436449 - Rename item_id to pocket_id for clearer way to identify saved Pocket items in NewTabUtils

https://reviewboard.mozilla.org/r/218556/#review224938

::: toolkit/modules/NewTabUtils.jsm:1385
(Diff revision 1)
> +   *@returns {Promise} Returns a promise at completion
> +   */
> +  deletePocketEntry(aItemID) {
> +    return new Promise((resolve, reject) => {
> +      pktApi.deleteItem(aItemID, {
> +        success() {

Pretty sure you can do `new Promise((success, error) => deleteItem(…, {success, error})` ?
Attachment #8949153 - Flags: review?(edilee) → review+
Pushed by usarracini@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/474bea93396d
Rename item_id to pocket_id for clearer way to identify saved Pocket items in NewTabUtils r=Mardak
https://hg.mozilla.org/mozilla-central/rev/474bea93396d
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 60
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: