Firefox window is always restored not maximized, also if it was maximized in the previous session

RESOLVED DUPLICATE of bug 1460639

Status

()

defect
P3
normal
RESOLVED DUPLICATE of bug 1460639
Last year
Last year

People

(Reporter: marco, Unassigned)

Tracking

({dataloss, regression, regressionwindow-wanted})

Trunk
Unspecified
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox58 wontfix, firefox59 wontfix, firefox60 affected, firefox61 affected)

Details

Attachments

(2 attachments)

The Firefox window is always restored not maximized for me, also if I always maximize it in my sessions.
Which OS are you seeing this on and which browser version?

It'd be good to see if QE can reproduce this once we have that info.
Flags: needinfo?(mcastelluccio)
Priority: -- → P3
Reporter

Comment 2

Last year
(In reply to Mike de Boer [:mikedeboer] from comment #1)
> Which OS are you seeing this on and which browser version?
> 
> It'd be good to see if QE can reproduce this once we have that info.

Linux (Ubuntu 17.10) with Nightly, but I've been seeing this for a while.

I can't reproduce in a clean profile.
Flags: needinfo?(mcastelluccio)
OS: Unspecified → Linux
(In reply to Marco Castelluccio [:marco] from comment #2)
> I can't reproduce in a clean profile.

Is there a way to bisect your prefs?
Reporter

Comment 4

Last year
Posted file aboutsupport.txt
(In reply to Andrew Overholt [:overholt] from comment #3)
> (In reply to Marco Castelluccio [:marco] from comment #2)
> > I can't reproduce in a clean profile.
> 
> Is there a way to bisect your prefs?

I've never heard of any automated way to do it, I would be happy if there was.

I'm attaching my about:support.
Reporter

Comment 5

Last year
I've noticed sometimes weird things happen in a clean profile too. I'm not sure if the they are the same bug.
Reporter

Updated

Last year
Duplicate of this bug: 1440240

Comment 7

Last year
I'm having (I believe) the same issue in Firefox 61 (2018-03-17 64-bit) on Windows 10 1709 Enterprise.

To reproduce:

1. Delete AppData\Local\Mozilla and AppData\Roaming\Mozilla to get a clean profile.
2. Open Firefox.
3. Maximize the Firefox window.
4. Close Firefox.
5. Open Firefox again.  The window will be restored, not maximized.


Settings that probably don't matter:

Resolution: 1920x1980
DPI: 150%
Windows user account is standard user, not admin

Comment 8

Last year
Interesting: it *does* remember the size of the window from your last session so long as the size of the window was not maximized.  The only window size that it will not remember from a previous session is a maximized window.
Note that Nightly had a similar bug filed against it more recently (bug 1446264), which is probably what comments 7-8 were seeing).

Marco, are you still seeing this?
Flags: needinfo?(mcastelluccio)
Yes, still happening. This is a much older regression.
Flags: needinfo?(mcastelluccio)
I'm also seeing this with today's local build. My STR is:

1. Resize Firefox window in any non-maximized mode
2. Maximize the window
3. Close Firefox
4. Restart Firefox

The window is opened as maximized but the contents of the window (including the UI controls) are the size of the non-maximized window I set previously.

Something similar already happened in the past, when launching I could see the non-maximized version of the window contents for a split-second and then the contents would be repainted to fill the maximized window.
BTW last week this wasn't happening, I can run a bisection if nobody else is doing it yet.
(In reply to Gabriele Svelto [:gsvelto] from comment #12)
> BTW last week this wasn't happening, I can run a bisection if nobody else is
> doing it yet.

Sure, a bisection would be helpful, but if it started only recently it might be a different bug (as I've been experiencing this for a while).
FYI I'm running the bisection right now.
Alright, sorry this took a while, the issue was introduced by bug 1453788.
Depends on: 1453788
Brendan, this issue seems to have been introduced by your patch. I had a quick look but I'm not familiar with that code so you're probably the best person to debug this. What seems to be happening is that the size of the inner window does not match that of the outer window once it's maximized. Additionally, when the window is first created it's not maximized, it gets maximized later but the contents are not resized.
Flags: needinfo?(bdahl)
Status: NEW → RESOLVED
Closed: Last year
Flags: needinfo?(bdahl)
Resolution: --- → DUPLICATE
Duplicate of bug: 1460639
Blocks: 1453788
No longer depends on: 1453788
You need to log in before you can comment on or make changes to this bug.