Mozilla Firefox Nightly 62.0a1 (2018-05-10) always starts in windowed/non-maximized mode

VERIFIED FIXED in Firefox 62

Status

()

defect
--
major
VERIFIED FIXED
a year ago
5 months ago

People

(Reporter: mr.rubot, Assigned: bdahl)

Tracking

({nightly-community, regression})

Trunk
Firefox 62
All
Windows
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox60 unaffected, firefox61 unaffected, firefox62- verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0
Build ID: 20180510100205
Summary: Nightly62-may10 will not start up full screen, must click on top right icon → Mozilla Firefox Nightly 62.0a1 (2018-05-10) always starts in windowed/non-maximized mode
Looking on Mozilla Firefox Nightly 62.0a1 (2018-05-10) daily pushlog,
these bugs seems most suspicious:
- Bug 1453788 - Remember window size and location for chrome HTML windows
- Bug 1460116 - Remove ShouldHideScrollbars
- Bug 1457338 - Tap in tab strip stops mouse drags

or it's missed call?
Component: Untriaged → General
Flags: needinfo?(xidorn+moz)
Flags: needinfo?(jhofmann)
Flags: needinfo?(bdahl)
OS: Unspecified → Windows
Hardware: Unspecified → All
Version: unspecified → Trunk
(Assignee)

Comment 3

a year ago
Pretty sure this is from my patch, I'll look into it.
Flags: needinfo?(xidorn+moz)
Flags: needinfo?(jhofmann)
Flags: needinfo?(bdahl)
(Assignee)

Updated

a year ago
Assignee: nobody → bdahl

Comment 4

a year ago
After manually testing the issue I found the following: 

Last good version: Nightly 62.0a1 – Build ID: 20180509100510 – (2018-05-09)
First bad version: Nightly 62.0a1 – Build ID:  20180510100205 – (2018-05-10)
(In reply to Timea Babos from comment #4)
> After manually testing the issue I found the following: 
> 
> Last good version: Nightly 62.0a1 – Build ID: 20180509100510 – (2018-05-09)
> First bad version: Nightly 62.0a1 – Build ID:  20180510100205 – (2018-05-10)

Good, but this is already written in bug summary ;)
Since this has an assignee and we'll see it in regression triage, I don't think we need to specially track it.
Comment hidden (mozreview-request)
(Assignee)

Comment 8

11 months ago
I'm also working on a test, but running into intermittent failures do to the way persist values are stored on a timer.

Comment 9

11 months ago
mozreview-review
Comment on attachment 8976629 [details]
Bug 1460639 - Apply persisted window settings before layout.

https://reviewboard.mozilla.org/r/244712/#review250844
Attachment #8976629 - Flags: review?(bugs) → review+
this code seems to be very regression prone, so it would be great to get some good tests.

Updated

11 months ago
Duplicate of this bug: 1462339
Comment hidden (mozreview-request)

Comment 13

11 months ago
mozreview-review
Comment on attachment 8979778 [details]
Bug 1460639 - Add test for loading persisted size of a navigated window.

https://reviewboard.mozilla.org/r/245926/#review252392

::: toolkit/content/tests/chrome/test_navigate_persist.html:42
(Diff revision 1)
> +      win.resizeTo(size, size);
> +      return resizePromise;
> +    }
> +
> +    async function runTest() {
> +      // Test that the persisted window attributes are loaded for browser.xul

I don't understand this comment. I don't see browser.xul being loaded anywhere.
I assume you mean window_navigate_persist.html
Attachment #8979778 - Flags: review?(bugs) → review+
(Assignee)

Updated

11 months ago
Duplicate of this bug: 1437647
Comment hidden (mozreview-request)
(Assignee)

Comment 17

11 months ago
mozreview-review
Comment on attachment 8979778 [details]
Bug 1460639 - Add test for loading persisted size of a navigated window.

https://reviewboard.mozilla.org/r/245926/#review252606

::: toolkit/content/tests/chrome/test_navigate_persist.html:42
(Diff revision 1)
> +      win.resizeTo(size, size);
> +      return resizePromise;
> +    }
> +
> +    async function runTest() {
> +      // Test that the persisted window attributes are loaded for browser.xul

I meant for the comment to overall describe what we're trying to test. I've updated it to clarify.

Comment 18

11 months ago
Pushed by bdahl@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4850c54a299a
Apply persisted window settings before layout. r=smaug
https://hg.mozilla.org/integration/autoland/rev/083bcc5bdad3
Add test for loading persisted size of a navigated window. r=smaug

Comment 19

11 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/4850c54a299a
https://hg.mozilla.org/mozilla-central/rev/083bcc5bdad3
Status: ASSIGNED → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62
I'm confirming that bug is fixed, starting in Mozilla Firefox Nightly 62.0a1 (2018-05-25), so I'm marking this bug as VERIFIED. Thank you very much! \o/
Status: RESOLVED → VERIFIED

Comment 21

11 months ago
I have always the problem with last version 62.0a1 (2018-05-24) (64-bit) Xubuntu 18.04 LTS x64
Problem not fixed

Comment 22

11 months ago
(In reply to comment #21)
> I have always the problem with last version 62.0a1 (2018-05-24)

The lastest build is 2018-05-26. If Nightly cannot update itself, download manually here:

http://ftp.mozilla.org/pub/firefox/nightly/latest-mozilla-central/
(In reply to Florent from comment #21)
> I have always the problem with last version 62.0a1 (2018-05-24) (64-bit)
> Xubuntu 18.04 LTS x64
> Problem not fixed

If you would read my comment #20, you will understand properly that this bug:
- is fixed starting in Mozilla Firefox Nightly 62.0a1 (2018-05-25)
- is not fixed in in Mozilla Firefox Nightly 62.0a1 (2018-05-24).

Comment 24

11 months ago
Sorry i thinked my Nightly have been updated.

Repository  http://ppa.launchpad.net/ubuntu-mozilla-daily/ppa/ubuntu is not update with the the last version

Updated

5 months ago
Duplicate of this bug: 1427310
You need to log in before you can comment on or make changes to this bug.