Closed Bug 1439059 Opened 2 years ago Closed 2 years ago

regression: tab loading animation is broken

Categories

(Core :: Graphics: WebRender, defect, P1)

x86_64
All
defect

Tracking

()

VERIFIED FIXED
mozilla60
Tracking Status
firefox-esr52 --- unaffected
firefox58 --- unaffected
firefox59 --- unaffected
firefox60 --- unaffected

People

(Reporter: darkspirit, Assigned: gw)

References

(Blocks 1 open bug, )

Details

(Keywords: nightly-community, regression)

Attachments

(2 files)

Attached video 2018-02-17_03-41-32.mp4
Switched to https://example.com and pressed F5.

try builds from bug 1437572:
> WR @ eceed87325ef1dbbd220a4ccbb9e7860f2679428 with the R8 failure fuzzed
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=1e055ce73a925afe1aca3c6bebb70f8863db03d4
mozregression --repo try --launch 1e055ce73a925afe1aca3c6bebb70f8863db03d4 --pref gfx.webrender.all:true startup.homepage_welcome_url:"about:newtab|about:newtab|https://example.com/"
good

> WR @ ac8fb3f6c77eee57aeac67301b0e6ef9e0818c7a
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=6cda8804c5fb0b7fec538f37f25a6726b31a9b72
mozregression --repo try --launch 6cda8804c5fb0b7fec538f37f25a6726b31a9b72 --pref gfx.webrender.all:true startup.homepage_welcome_url:"about:newtab|about:newtab|https://example.com/"
good

> WR @ ac8fb3f6c77eee57aeac67301b0e6ef9e0818c7a
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=86417389def170a478482cd30b225b0b13dee95d
mozregression --repo try --launch 86417389def170a478482cd30b225b0b13dee95d --pref gfx.webrender.all:true startup.homepage_welcome_url:"about:newtab|about:newtab|https://example.com/"
good

> WR @ 38df48c62c929a3603f3c6e6393c2be8f1c88903
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=064776f7e05b066c4ad40181ba397b751dcfd477
mozregression --repo try --launch 064776f7e05b066c4ad40181ba397b751dcfd477 --pref gfx.webrender.all:true startup.homepage_welcome_url:"about:newtab|about:newtab|https://example.com/"
good

> WR @ d69bd28a055e2afb2ad234eea297dd45f9b4b4e5
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=51cf20720ce738e9a9bb1a1b65ec4a2efb797f69
mozregression --repo try --launch 51cf20720ce738e9a9bb1a1b65ec4a2efb797f69 --pref gfx.webrender.all:true startup.homepage_welcome_url:"about:newtab|about:newtab|https://example.com/"
bad (screencast)

> WR @ 377e2b22c61dd67ae4d746d50af09a7e5241bd9f
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=b9bfc8e4c45e341cb9132d5f8d41fbc9f0cd45ef
mozregression --repo try --launch b9bfc8e4c45e341cb9132d5f8d41fbc9f0cd45ef --pref gfx.webrender.all:true startup.homepage_welcome_url:"about:newtab|about:newtab|https://example.com/"
bad

> WR @ 4af31b8aa79d5a1f3c0242dea6be4876c71075c5
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=6c6a0d0429e423f59a6ba85fa06e307a8ece6ead
mozregression --repo try --launch 6c6a0d0429e423f59a6ba85fa06e307a8ece6ead --pref gfx.webrender.all:true startup.homepage_welcome_url:"about:newtab|about:newtab|https://example.com/"
bad

Regression range: https://github.com/servo/webrender/compare/38df48c62c929a3603f3c6e6393c2be8f1c88903...d69bd28a055e2afb2ad234eea297dd45f9b4b4e5
Duplicate of this bug: 1439083
FWIW, I am seeing a worse effect on many pages, like this bugzilla page. See the attached video "Peek 2018-02-17 11-26". For whatever reason, example.com shows a similar effect as comment 0 describes. 

mozregression points to the same bug as causing the regression.
This can vary a lot: The more tabs I've opened, the less buggy it looks. Sometimes I even see the tab title a second time below the real one. (Quantum Lights theme)
Another fun way to produce glitches is to click the plus and minus buttons to zoom the map on http://www.senecacollege.ca/campuses/janelocation.html .
OS: Linux → All
Duplicate of this bug: 1439149
Duplicate of this bug: 1439257
Assignee: nobody → gwatson
Priority: -- → P1
I can reproduce this locally, and have a wrench capture of the bug.

So far, it seems that the blend primitive is being drawn with unclipped bounds, which is why it draws much larger than it should be, including the contents of other parts of the render target cache.
It seems that only the tab loading animation and whatsapp's file sending menu are fixed by servo/webrender#2443.
Depends on: 1440664
Duplicate of this bug: 1442164
Verified fixed in Nightly 60 x64 20180302104326 de_DE b2a9a4bb5c94de179ae7a3f52fde58c0e2897498 @ Debian Testing. Thanks!
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.