Closed Bug 1439096 Opened 2 years ago Closed 2 years ago

Crash in RtlRaiseStatus | RtlpWaitOnCriticalSection | RtlpEnterCriticalSectionContended | RtlEnterCriticalSection | mozilla::BaseAutoLock<T>::BaseAutoLock<T>

Categories

(Core :: Networking: DNS, defect, P1, critical)

Unspecified
Windows 10
defect

Tracking

()

RESOLVED FIXED
mozilla60
Tracking Status
firefox-esr52 --- unaffected
firefox58 --- unaffected
firefox59 --- unaffected
firefox60 --- fixed

People

(Reporter: calixte, Assigned: valentin)

References

(Blocks 1 open bug)

Details

(Keywords: crash, regression, Whiteboard: [necko-triaged][trr])

Crash Data

This bug was filed from the Socorro interface and is
report bp-e498a3e8-ef90-473a-9117-5ee810180216.
=============================================================

Top 10 frames of crashing thread:

0 ntdll.dll RtlRaiseStatus 
1 ntdll.dll RtlpWaitOnCriticalSection 
2 ntdll.dll RtlpEnterCriticalSectionContended 
3 ntdll.dll RtlEnterCriticalSection 
4 xul.dll mozilla::BaseAutoLock<mozilla::Mutex>::BaseAutoLock<mozilla::Mutex> xpcom/threads/Mutex.h:166
5 xul.dll nsHostResolver::CompleteLookup netwerk/dns/nsHostResolver.cpp:1598
6 xul.dll nsHostResolver::ThreadFunc netwerk/dns/nsHostResolver.cpp:1852
7 nss3.dll PR_NativeRunThread nsprpub/pr/src/threads/combined/pruthr.c:397
8 nss3.dll pr_root nsprpub/pr/src/md/windows/w95thred.c:137
9 ucrtbase.dll thread_start<unsigned int > 

=============================================================

There are 4 crashes (from 4 installations) in nightly 60 with buildid 20180216104033. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1434852.

[1] https://hg.mozilla.org/mozilla-central/rev?node=6776d69d2f03
Flags: needinfo?(daniel)
Crash Signature: [@ RtlRaiseStatus | RtlpWaitOnCriticalSection | RtlpEnterCriticalSectionContended | RtlEnterCriticalSection | mozilla::BaseAutoLock<T>::BaseAutoLock<T>] → [@ RtlRaiseStatus | RtlpWaitOnCriticalSection | RtlpEnterCriticalSectionContended | RtlEnterCriticalSection | mozilla::BaseAutoLock<T>::BaseAutoLock<T>] [@ RtlpWaitOnCriticalSection | RtlpEnterCriticalSectionContended | RtlEnterCriticalSection | mozilla:…
Crash Signature: mozilla::MonitorAutoLock::MonitorAutoLock ] → mozilla::MonitorAutoLock::MonitorAutoLock ] [@ RtlRaiseStatus | RtlpWaitOnCriticalSection | RtlpEnterCriticalSectionContended | RtlEnterCriticalSection | mozilla::MonitorAutoLock::MonitorAutoLock]
Crash Signature: mozilla::MonitorAutoLock::MonitorAutoLock ] [@ RtlRaiseStatus | RtlpWaitOnCriticalSection | RtlpEnterCriticalSectionContended | RtlEnterCriticalSection | mozilla::MonitorAutoLock::MonitorAutoLock] → mozilla::MonitorAutoLock::MonitorAutoLock] [@ RtlRaiseStatus | RtlpWaitOnCriticalSection | RtlpEnterCriticalSectionContended | RtlEnterCriticalSection | mozilla::MonitorAutoLock::MonitorAutoLock] [@ RtlpWaitOnCriticalSection | RtlDeNormalizeProcessPara…
Duplicate of this bug: 1439138
Crash Signature: RtlDeNormalizeProcessParams | mozilla::BaseAutoLock<T>::BaseAutoLock<T>] → RtlDeNormalizeProcessParams | mozilla::BaseAutoLock<T>::BaseAutoLock<T>] [@ RtlRaiseStatus | RtlpWaitOnCriticalSection | RtlpEnterCriticalSectionContended | RtlEnterCriticalSection | nsHostResolver::CompleteLookup] [@ RtlpWaitOnCriticalSection | RtlpEn…
Assignee: nobody → daniel
Flags: needinfo?(daniel)
Priority: -- → P1
Whiteboard: [necko-triaged]
Whiteboard: [necko-triaged] → [necko-triaged][trr]
20 crashes, the last one on buildid 20180219100221
Last build ID 20180220103456. Seems to be fixed by bug 1439538
Status: NEW → RESOLVED
Closed: 2 years ago
Depends on: 1439538
Resolution: --- → FIXED
Assignee: daniel → valentin.gosu
Target Milestone: --- → mozilla60
You need to log in before you can comment on or make changes to this bug.