add View->Messages->Hide Deleted Messages to mail news front end

VERIFIED DUPLICATE of bug 98097

Status

--
enhancement
VERIFIED DUPLICATE of bug 98097
17 years ago
14 years ago

People

(Reporter: mozilla.gv6r, Assigned: sspitzer)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Would be nice to be able to hide messages that have been deleted (but not yet
removed entirely), so they don't take up so much space on the display before
compaction.

It shouldn't be automatic, but I think it should be possible.  This has been a
feature I would have liked to have since Netscape 4, or possibly before.
(Reporter)

Comment 1

17 years ago
To duplicate:
1) Use an IMAP server
2) Open Messenger
3) Set "Edit->Mail and Newsgroup Account Settings..." Server Settings "When I
delete a message:" "Mark it as deleted."
4) OK the account settings dialog, and choose a message that you don't want to keep.
5) Delete message.  Message is now marked deleted, but still present in list of
messages, as expected.

Since I have some filters running that move/delete messages which I'm still
debuging (my filters, not the application itself), I like having the deleted
messages just get marked deleted.  But it would be nice if I could hide those
deleted messages without having to change the server settings.

A possible workaround is to change "When I delete a message:" to "move message
to trash".  This seems to be acceptable for now, but I do kind of wonder why
we've got a method to mark a message deleted, but not really do anything with
those messages until the folder is compacted.

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 98097 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
Verified dup
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.