Closed
Bug 1439993
Opened 8 years ago
Closed 8 years ago
Remove COMPILE_DIR => setting from Bugzilla::Template when effective group != webservergroup to prevent filesystem permission errors
Categories
(bugzilla.mozilla.org :: General, enhancement)
Tracking
()
VERIFIED
FIXED
People
(Reporter: aflorinescu, Assigned: glob)
References
Details
Attachments
(1 file)
[Description:]
QA Eng. team uses the whining system to keep track of our various triage lists. There are about 16 whines that we are using configured as follows:
- Schedule - at midnight
- Several custom queries (1-2 searches per whine)
- alias + single emails
I also set a test whining earlier, to send whines every 15 minutes + a fixed schedule for 02-21-2018 05:00 PST, and nothing was received.
Flags: needinfo?(dylan)
| Reporter | ||
Comment 1•8 years ago
|
||
Bumping up the severity to "blocker" since this issue is indeed a blocker for our triage process.
Severity: major → blocker
Comment 2•8 years ago
|
||
So something changed (maybe the feed daemon? Not sure) but basically template_cache/template/en/default/ was created with the wrong permissions. Apparently the behavior of the templating engine when it can't write out the compiled version of a template is to throw an exception. These exceptions get emailed (to me) but I didn't differentiate them from warnings.
In the mean time, the file permission issue is fixed and I'm going to remove the save-compiled-templates-to-dir option.
We don't make use of this feature in the web app portion (compiled templates are stored in RAM) anyway.
Flags: needinfo?(dylan)
Summary: Starting with 02-20-2018 whinings fail to be be delivered → Remove COMPILE_DIR => setting from Bugzilla::Template to prevent filesystem permission errors
Updated•8 years ago
|
Summary: Remove COMPILE_DIR => setting from Bugzilla::Template to prevent filesystem permission errors → Remove COMPILE_DIR => setting from Bugzilla::Template when effective group != webservergroup to prevent filesystem permission errors
Assignee: nobody → glob
Severity: blocker → normal
Component: Administration → General
Updated•8 years ago
|
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
| Reporter | ||
Comment 4•8 years ago
|
||
I am assuming this issue was tracking our use of the whining system, which is working properly after the fix. With that in mind, marking this as verified.
Status: RESOLVED → VERIFIED
You need to log in
before you can comment on or make changes to this bug.
Description
•