Closed Bug 1441500 Opened 3 years ago Closed 3 years ago

Remove smoothing of delayTime in DelayNode

Categories

(Core :: Web Audio, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
mozilla60
Tracking Status
firefox60 --- fixed

People

(Reporter: padenot, Assigned: padenot)

References

Details

Attachments

(1 file)

No description provided.
Rank: 25
Priority: -- → P3
Comment on attachment 8954332 [details]
Bug 1441500 - Remove smoothing of the delayTime parameter.

https://reviewboard.mozilla.org/r/223436/#review229530


Code analysis found 3 defects in this patch:
 - 3 defects found by clang-tidy

You can run this analysis locally with:
 - `./mach static-analysis check path/to/file.cpp` (C/C++)


If you see a problem in this automated review, please report it here: http://bit.ly/2y9N9Vx


::: dom/media/webaudio/DelayBuffer.h:22
(Diff revision 1)
>  class DelayBuffer final
>  {
>    typedef dom::ChannelInterpretation ChannelInterpretation;
>  
>  public:
> -  // See WebAudioUtils::ComputeSmoothingRate() for frame to frame exponential
> +  DelayBuffer(double aMaxDelayTicks)

Error: Bad implicit conversion constructor for 'delaybuffer' [clang-tidy: mozilla-implicit-constructor]

::: dom/media/webaudio/DelayBuffer.h:22
(Diff revision 1)
>  class DelayBuffer final
>  {
>    typedef dom::ChannelInterpretation ChannelInterpretation;
>  
>  public:
> -  // See WebAudioUtils::ComputeSmoothingRate() for frame to frame exponential
> +  DelayBuffer(double aMaxDelayTicks)

Error: Bad implicit conversion constructor for 'delaybuffer' [clang-tidy: mozilla-implicit-constructor]

::: dom/media/webaudio/DelayBuffer.h:22
(Diff revision 1)
>  class DelayBuffer final
>  {
>    typedef dom::ChannelInterpretation ChannelInterpretation;
>  
>  public:
> -  // See WebAudioUtils::ComputeSmoothingRate() for frame to frame exponential
> +  DelayBuffer(double aMaxDelayTicks)

Error: Bad implicit conversion constructor for 'delaybuffer' [clang-tidy: mozilla-implicit-constructor]
This will fix half of the failing test for 1440806 (but we still need OfflineAudioContext.suspend).
Comment on attachment 8954332 [details]
Bug 1441500 - Remove smoothing of the delayTime parameter.

https://reviewboard.mozilla.org/r/223436/#review229692

Thank you, Paul!  I'm very pleased to see this go :)

::: dom/media/webaudio/DelayBuffer.h:22
(Diff revision 1)
>  class DelayBuffer final
>  {
>    typedef dom::ChannelInterpretation ChannelInterpretation;
>  
>  public:
> -  // See WebAudioUtils::ComputeSmoothingRate() for frame to frame exponential
> +  DelayBuffer(double aMaxDelayTicks)

explicit

::: dom/media/webaudio/DelayBuffer.h
(Diff revision 1)
>    // Each delay should be >= 0 and <= MaxDelayTicks().
>    void Read(const double aPerFrameDelays[WEBAUDIO_BLOCK_SIZE],
>              AudioBlock* aOutputChunk,
>              ChannelInterpretation aChannelInterpretation);
> -  // Read a block with a constant delay, which will be smoothed with the
> +  // Read a block with a constant delay.
> -  // previous delay.  The delay should be >= 0 and <= MaxDelayTicks().

I don't know whether or not you intended to remove the sentence about the bounds of the delay.

I don't really mind because it is stated for the other Read() method, but keeping would be more clear I guess.
Attachment #8954332 - Flags: review?(karlt) → review+
Pushed by paul@paul.cx:
https://hg.mozilla.org/integration/autoland/rev/9d8ced63dfc6
Remove smoothing of the delayTime parameter. r=karlt
https://hg.mozilla.org/mozilla-central/rev/9d8ced63dfc6
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
Duplicate of this bug: 952980
You need to log in before you can comment on or make changes to this bug.