Closed Bug 1441868 Opened 3 years ago Closed 3 years ago

--console-output-indent-width is defined but never referenced

Categories

(DevTools :: Console, defect)

defect
Not set
normal

Tracking

(firefox-esr52 unaffected, firefox58 unaffected, firefox59+ verified, firefox60 verified)

VERIFIED FIXED
Firefox 60
Tracking Status
firefox-esr52 --- unaffected
firefox58 --- unaffected
firefox59 + verified
firefox60 --- verified

People

(Reporter: jaws, Assigned: nchevobbe)

References

Details

(Keywords: regression)

Attachments

(1 file)

[Tracking Requested - why for this release]: new regression introduced in 59, should fix before 59 is released. 

This is a regression from bug 1427595. It is unclear to me what the repercussions of this regression are.
Flags: needinfo?(nchevobbe)
This css property was used to handle indent in the Tree we have to inspect objects.
It was deprecated in the component code, but not removed from webconsole.css I guess.

BTW Bug 1441871 is similar, can we dupe it and I'll fix those in this bug ?
Flags: needinfo?(nchevobbe)
Flags: needinfo?(jaws)
Feel free to dupe the bugs as you see fit. I've got a patch in bug 1441882 that flagged these unused properties and so I filed bugs for the errors that it had found.
Flags: needinfo?(jaws)
Duplicate of this bug: 1441871
Comment on attachment 8954821 [details]
Bug 1441868 - Remove unused css properties; .

https://reviewboard.mozilla.org/r/223974/#review229946
Attachment #8954821 - Flags: review?(bgrinstead) → review+
Can you please include --theme-search-overlays-semitransparent here too?
Assignee: nobody → nchevobbe
Status: NEW → ASSIGNED
I'd rather not since it's on the debugger panel, and it should be handled in Github.
Can you file a bug and needinfo jlast or yulia so they can have a proper look ?
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4ba5232e1ff1
Remove unused css properties; r=bgrins.
https://hg.mozilla.org/mozilla-central/rev/4ba5232e1ff1
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 60
OK, if it seems like it may be a major regression, please request uplift to m-r. This can still make Monday's RC1 build.   

Andrei, could someone from your team verify the fix, since this is a last minute change?
Flags: needinfo?(andrei.vaida)
I don't really understand how this would be a problem though. Because web devs might apply them in the console and expect them to work, but there would be no effect or some annoying errors?
(In reply to Liz Henry (:lizzard) (needinfo? me) from comment #12)
> I don't really understand how this would be a problem though. Because web
> devs might apply them in the console and expect them to work, but there
> would be no effect or some annoying errors?

There are two effects of the bug:
- the unused CSS variable which would cause extra logs in the Browser Console (not visible to the average user). 
- the visual part changes the color of the line that appears below the arrow when you do `console.warn(window)` or `console.error(window)` and expand the object to be white instead of blue (since it is against a yellow/red background)

Neither are big issues but if the visual portion is verified I don't think there'd be harm in including in 59.
Flags: needinfo?(nchevobbe)
Accidentally set needinfo
Flags: needinfo?(nchevobbe)
(In reply to Liz Henry (:lizzard) (needinfo? me) from comment #11)
> OK, if it seems like it may be a major regression, please request uplift to
> m-r. This can still make Monday's RC1 build.   

This needs an approval request ASAP if there's any chance of it making Monday's RC1 build.
Flags: needinfo?(nchevobbe)
Comment on attachment 8954821 [details]
Bug 1441868 - Remove unused css properties; .

Approval Request Comment
[Feature/Bug causing the regression]:
Bug 1427595

[User impact if declined]:
There are two effects of the bug:
- the unused CSS variable which would cause extra logs in the Browser Console (not visible to the average user). 
- the visual part changes the color of the line that appears below the arrow when you do `console.warn(window)` or `console.error(window)` and expand the object to be white instead of blue (since it is against a yellow/red background)

[Is this code covered by automated tests?]:
No

[Has the fix been verified in Nightly?]:
Yes

[Needs manual test from QE? If yes, steps to reproduce]: 
No

[List of other uplifts needed for the feature/fix]:
None

[Is the change risky?]:
No

[Why is the change risky/not risky?]:
Small visual change in devtools webconsole

[String changes made/needed]:
No
Flags: needinfo?(nchevobbe)
Attachment #8954821 - Flags: approval-mozilla-beta?
Attachment #8954821 - Flags: approval-mozilla-beta? → approval-mozilla-release?
Comment on attachment 8954821 [details]
Bug 1441868 - Remove unused css properties; .

Minor devtools CSS fix. Approved for 59rc1.
Attachment #8954821 - Flags: approval-mozilla-release? → approval-mozilla-release+
I reproduced this issue using Fx 60.0a1 (build ID: 20180228220115), on Windows 10 x64.
I can confirm this issue is fixed, I verified using Fx 60.0a1 (build ID: 20180306100123) and Fx 59.0, on Windows 10 x64, mac OS X 10.13.2 and Ubuntu 16.04 x86 LTS.
Status: RESOLVED → VERIFIED
Flags: needinfo?(andrei.vaida)
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.