Console has white background on mouseover making it hard to read

VERIFIED FIXED in Firefox 59

Status

P1
normal
VERIFIED FIXED
11 months ago
5 months ago

People

(Reporter: nachtigall, Assigned: nchevobbe)

Tracking

Trunk
Firefox 59
All
Unspecified

Firefox Tracking Flags

(firefox59 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 months ago
Created attachment 8939374 [details]
bgconsole.gif

Today's nightly (updated today from 23th dec) has white bg in dark theme on mouseover. Makes it hard reading. See screenshot.

I talked to Nicolas on twitter (https://twitter.com/nactgl/status/948178408462278656) and he'll be looking into it.
(Reporter)

Updated

11 months ago
Flags: needinfo?(nchevobbe)
(Assignee)

Comment 1

11 months ago
Looking into it. I thought we had something to turn off the hover background on tree nodes, maybe the new reps release changed something there.
Assignee: nobody → nchevobbe
Status: NEW → ASSIGNED
Flags: needinfo?(nchevobbe)
Priority: -- → P1
Comment hidden (mozreview-request)

Comment 3

11 months ago
mozreview-review
Comment on attachment 8939506 [details]
Bug 1427595 - Fix ObjectInspector css regressed by devtools-reps-0.16.0; .

https://reviewboard.mozilla.org/r/209840/#review215374

Looks good and fixes the issue for me.

R+ assuming my inline comment is resolved.

Thanks Nicolas!
Honza

::: devtools/client/themes/webconsole.css:1201
(Diff revision 1)
> +}
> +
> -  /*
> +/*
> -   * Make the arrow the same color and approximately the same size of the twisty icon.
> +  * Make the arrow the same color and approximately the same size of the twisty icon.
> -   * Should be properly fixed in https://bugzilla.mozilla.org/show_bug.cgi?id=1307937.
> +  * Should be properly fixed in https://bugzilla.mozilla.org/show_bug.cgi?id=1307937.
> -   */
> +  */

nit: the block comment doesn't seem to be properly indented.
Attachment #8939506 - Flags: review?(odvarko) → review+
Comment hidden (mozreview-request)

Comment 5

11 months ago
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/19c8ceb894b8
Fix ObjectInspector css regressed by devtools-reps-0.16.0; r=Honza.

Comment 6

11 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/19c8ceb894b8
Status: ASSIGNED → RESOLVED
Last Resolved: 11 months ago
status-firefox59: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
QA Whiteboard: [good first verify]

Comment 7

9 months ago
I have reproduced this bug with Nightly 59.0a1 (2018-01-02) on Windows 10, 64 bit

The bug's fix is now verified with Latest Beta 59.0b10

Build ID 	20180215111455
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
QA Whiteboard: [good first verify] → [good first verify] [testday-20180216]

Comment 8

9 months ago
I can seem to be able to reproduce the bug. Can you please verify if the bug is still reproducing on Ubuntu and macOS, too? Or did you change the brightness of your monitor? Because the text is highlighted when the cursor hovers over it, but I didn't get such a bright background.
User Agent : Mozilla/5.0 (Linux Ubuntu 16.04; 64 bit) Firefox/59.0 beta 14

I tried to reproduce the bug , but i think its solved now . Unable to reproduce on Ubuntu.

Comment 10

9 months ago
I have Tried to Reproduce this same bug with Firefox Beta 59.0b14 (32bit) on Ubuntu Mate (Linux 4.13.0-36-generic) 

But the Bug has been Fixed. 
--------------------------------------------------------------------------------
Firefox Version 59.0b14
Build ID: 20180301022608
User Agent: Mozilla/5.0 (X11; Linux i686; rv:59.0) Gecko/20100101 Firefox/59.0
OS: Linux 4.13.0-36-generic
--------------------------------------------------------------------------------

[Steps to reproduce]
1) Start firefox with Cleaned Profile
2) Open the Browser Console by Clicking on Tools -> Web developer -> Web Console or Press (Ctrl+shift+k) 
3) Now Open Any Websites like https://www.google.com
4) Observe in Console logs

[Actual Results]
Console doesn't displaying White background, while moving mouse hover

Status: Fixed & Verified

[testday-20180302]
Status: RESOLVED → VERIFIED

Updated

5 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.