Keyboard focus is wrong after selecting page from history

RESOLVED WORKSFORME

Status

SeaMonkey
Bookmarks & History
--
minor
RESOLVED WORKSFORME
16 years ago
5 years ago

People

(Reporter: Scott Gifford (old account), Unassigned)

Tracking

(Blocks: 1 bug)

SeaMonkey 1.1 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [history][2012 Fall Equinox][CLOSEME 2012-11-01 WFM])

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc2) Gecko/20020510
BuildID:    2002051009

After selecting a page frome the history window, when I hit CTRL-F to search
that page, it instead searches history.


Reproducible: Always
Steps to Reproduce:
1. Select Go|History from the menu
2. Select any page in your history, and double-click on it.
3. Hit CTRL-F.


Actual Results:  The "Find in History" window pops up.


Expected Results:  The "Find in Page" window popping up.

Comment 1

16 years ago
Checked on mozilla1.0rc3-talkback on Win NT 4.0

This behaviour is not seen.
(Reporter)

Comment 2

16 years ago
Still see it in 1.0RC3 (2002052309) on Linux.
Reporter: IS this still a problem with 1.1b ?
(Reporter)

Comment 4

16 years ago
Yup, just tested with:
Mozilla 1.1b
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020722

Comment 5

15 years ago
Reporter:  after you double-click the site in the history window, which window
has focus (the history window or the browser window)?
Keywords: qawanted

Comment 6

15 years ago
Benjamin - The history window.

Comment 7

15 years ago
->XP Apps: GUI Features -- This bug does not appear on Windows.  I don't have a
working linux build right now, but tomorrow or the next I will test and confirm
this.  It shouldn't be hard to fix this, as it is simply a focus issue.
Assignee: Matti → blaker
Severity: normal → minor
Status: UNCONFIRMED → NEW
Component: Browser-General → XP Apps: GUI Features
Ever confirmed: true
QA Contact: imajes-qa → paw

Comment 8

14 years ago
This bug can be closed as it's not present in the current build: Mozilla/5.0
(X11; U; Linux i686; en-US; rv:1.5) Gecko/20031029.

Double-clicking in the history window gives focus to the browser window in which
the URL is being opened, and Ctrl-F searches in the page as it should.

Comment 9

14 years ago
I still see this bug in

  Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7a) Gecko/20040101

exactly as described here.  It works fine in Firebird, though.

Comment 10

14 years ago
This could be a window manager issue. You say in comment #6 that the history
window retains its focus, which is why Ctrl-F activates "Find in history". In my
case, double-click in the history window raises the browser and gives it the
focus  (IceWM in click-to-focus mode). Could you give details of your window
manager and its setup?

Comment 11

14 years ago
sawfish v1.0, click-to-focus.

Comment 12

14 years ago
Reassigning obsolete bugs to their respective Seamonkey owners (i.e. nobody). 
If you want this fixed for Firefox, change the Product and Component accordingly
and reassign back to me.
Assignee: firefox → guifeatures

Updated

13 years ago
Blocks: 83552
Product: Core → Mozilla Application Suite

Comment 13

13 years ago
I still see this with linux trunk 2005032805 with click-to-focus, although
sloppy focus works fine.
Keywords: qawanted
Filter "spam" on "guifeatures-nobody-20080610".
Assignee: guifeatures → nobody
QA Contact: pawyskoczka → guifeatures

Updated

9 years ago
Component: XP Apps: GUI Features → UI Design

Updated

9 years ago
Duplicate of this bug: 411522

Updated

9 years ago
Version: Trunk → SeaMonkey 1.1 Branch

Updated

8 years ago
Whiteboard: [history]

Updated

7 years ago
Component: UI Design → Bookmarks & History
QA Contact: ui-design → bookmarks

Comment 16

5 years ago
WFM here, is anybody still able to reproduce this?
User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 SeaMonkey/2.15a1
Build identifier: 20120921003032
Whiteboard: [history] → [history][2012 Fall Equinox][CLOSEME 2012-11-01 WFM]

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.