Closed Bug 1442925 Opened 3 years ago Closed 3 years ago

Searchbar broken in SeaMonkey "this._textbox.FormHistory is undefined"

Categories

(SeaMonkey :: Search, defect)

defect
Not set
normal

Tracking

(seamonkey2.53 fixed, seamonkey2.57esr fixed)

RESOLVED FIXED
seamonkey2.57
Tracking Status
seamonkey2.53 --- fixed
seamonkey2.57esr --- fixed

People

(Reporter: frg, Assigned: frg)

References

Details

(Whiteboard: SM2.53.1)

Attachments

(2 files)

Older error when you drag the search filed into a toolbar.:

[JavaScript Error: "TypeError: this._textbox.mController is undefined" {file: "chrome://communicator/content/search/search.xml" line: 99}]
searchbar_XBL_Destructor@chrome://communicator/content/search/search.xml:99:1
onToolbarDrop@chrome://communicator/content/customizeToolbar.js:738:7
EventListener.handleEvent*InitWithToolbox@chrome://communicator/content/customizeToolbar.js:42:5
onLoad@chrome://communicator/content/customizeToolbar.js:17:5
onload@chrome://communicator/content/customizeToolbar.xul:1:1

This was fixed in Bug 1106432 for Firefox.

New error. The search does not work in 2.57 (maybe even earlier.
TypeError: this._textbox.FormHistory is undefined[Learn More]  search.xml:469:13
	doSearch chrome://communicator/content/search/search.xml:469:13
	handleSearchCommand chrome://communicator/content/search/search.xml:459:11
	onclick chrome://navigator/content/navigator.xul:1:1
> New error. The search does not work in 2.57 (maybe even earlier.

Actually the autocomplete popup does not work.
This should go into 2.49 too I think.
Attachment #8955824 - Flags: review?(iann_bugzilla)
Attachment #8955824 - Flags: approval-comm-esr52?
Changed some observer calls here too to align it with Fx. Can take them out if not ok.
Attachment #8955825 - Flags: review?(iann_bugzilla)
Comment on attachment 8955824 [details] [diff] [review]
1442925-part1-searchbarinitialize.patch

LGTM r/a=me
Attachment #8955824 - Flags: review?(iann_bugzilla)
Attachment #8955824 - Flags: review+
Attachment #8955824 - Flags: approval-comm-esr52?
Attachment #8955824 - Flags: approval-comm-esr52+
Comment on attachment 8955825 [details] [diff] [review]
1442925-part2-search.patch

LGTM r=me
Attachment #8955825 - Flags: review?(iann_bugzilla) → review+
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/3736b11f0775
Fix leak caused by XBL in toolbarless popups. r=IanN
https://hg.mozilla.org/comm-central/rev/1cb55e399e91
Fix TypeError: this._textbox.FormHistory in Searchbar. r=IanN
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Comment on attachment 8955825 [details] [diff] [review]
1442925-part2-search.patch

Not broken in 2.53 but helps keeping the trees in sync.
Attachment #8955825 - Flags: approval-comm-release+
Target Milestone: --- → seamonkey2.57
Regressions: 1615239
Whiteboard: SM2.53.1
You need to log in before you can comment on or make changes to this bug.