Closed Bug 1443318 Opened 2 years ago Closed 2 years ago

Intermittent browser_check_identity_state.js,browser_urlbarAboutHomeLoading.js,browser_remoteness_flip_on_restore.js | Uncaught exception - at chrome://global/content/bindings/tabbox.xml:384 - TypeError: this.tabbox is undefined

Categories

(Firefox :: Tabbed Browser, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Firefox 60
Tracking Status
firefox-esr52 --- unaffected
firefox58 --- unaffected
firefox59 --- unaffected
firefox60 --- fixed

People

(Reporter: dao, Assigned: dao)

References

Details

(Keywords: intermittent-failure, regression, Whiteboard: [stockwell fixed:product])

Attachments

(1 file)

https://treeherder.mozilla.org/logviewer.html#?job_id=166063779&repo=autoland&lineNumber=3475

TEST-UNEXPECTED-FAIL | browser/base/content/test/siteIdentity/browser_check_identity_state.js | Uncaught exception - at chrome://global/content/bindings/tabbox.xml:384 - TypeError: this.tabbox is undefined
Stack trace:
    set_selectedIndex@chrome://global/content/bindings/tabbox.xml:384:15
    set_selectedItem@chrome://global/content/bindings/tabbox.xml:420:34
    set_selectedTab@chrome://global/content/bindings/tabbox.xml:100:15
    set selectedTab@chrome://browser/content/tabbrowser.js:296:5
    openNewForegroundTab/promises<@resource://testing-common/BrowserTestUtils.jsm:196:44
    switchTab@resource://testing-common/BrowserTestUtils.jsm:237:7
    openNewForegroundTab@resource://testing-common/BrowserTestUtils.jsm:190:9
    pbModeTest@chrome://mochitests/content/browser/browser/base/content/test/siteIdentity/browser_check_identity_state.js:381:22
    async*test_pb_mode@chrome://mochitests/content/browser/browser/base/content/test/siteIdentity/browser_check_identity_state.js:409:9
    Async*Tester_execTest/<@chrome://mochikit/content/browser-test.js:1067:21
    Tester_execTest@chrome://mochikit/content/browser-test.js:1058:9
    Tester.prototype.nextTest</<@chrome://mochikit/content/browser-test.js:958:9
    SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:795:59

I expect this is due the "tabbox" property being set in the TabBrowser constructor directly rather than lazily. Alas, just accessing DOM node like this invokes XBL.
Duplicate of this bug: 1443362
Summary: Intermittent browser_check_identity_state.js | Uncaught exception - TypeError: this.tabbox is undefined → Intermittent browser/base/content/test/siteIdentity/browser_check_identity_state.js | Uncaught exception - at chrome://global/content/bindings/tabbox.xml:384 - TypeError: this.tabbox is undefined
Assignee: nobody → dao+bmo
Depends on: 1442398
Priority: -- → P1
browser_urlbarAboutHomeLoading.js: https://treeherder.mozilla.org/logviewer.html#?job_id=166209440&repo=try
browser_remoteness_flip_on_restore.js: https://treeherder.mozilla.org/logviewer.html#?job_id=166209453&repo=try
Summary: Intermittent browser/base/content/test/siteIdentity/browser_check_identity_state.js | Uncaught exception - at chrome://global/content/bindings/tabbox.xml:384 - TypeError: this.tabbox is undefined → Intermittent browser_check_identity_state.js,browser_urlbarAboutHomeLoading.js,browser_remoteness_flip_on_restore.js | Uncaught exception - at chrome://global/content/bindings/tabbox.xml:384 - TypeError: this.tabbox is undefined
Recently I have been getting this "TypeError: this.tabbox is undefined" error when using Nightly.

It happens sometimes when I open a new window, then the tabbar doesn't work properly. I can click another tab but the content window does not change.

Doesn't always happen and I don't have more precise steps to reproduce. When it happens, closing the bad window and opening a new one does not fix the problem, but restarting the browser usually does.
Depends on: 1443837
Depends on: 1443849
No longer depends on: 1443837
gBrowser.init currently sets tabContainer before tabbox. But the tabContainer constructor needs the tabbox:

https://searchfox.org/mozilla-central/rev/33cc9e0331da8d9ff3750f1e68d72d61201176cb/toolkit/content/widgets/tabbox.xml#240

So I think an easy fix is to set tabbox before tabContainer. I will still pursue bug 1443849 regardless.
Comment on attachment 8957116 [details]
Bug 1443318 - Set tabbox before tabContainer in gBrowser.init since the tabContainer's XBL constructor needs the tabbox.

https://reviewboard.mozilla.org/r/226058/#review232004
Attachment #8957116 - Flags: review?(gijskruitbosch+bugs) → review+
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3934ce46a591
Set tabbox before tabContainer in gBrowser.init since the tabContainer's XBL constructor needs the tabbox. r=Gijs
https://hg.mozilla.org/mozilla-central/rev/3934ce46a591
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 60
Duplicate of this bug: 1444165
No longer blocks: 1444165
Whiteboard: [stockwell disable-recommended] → [stockwell fixed:product]
You need to log in before you can comment on or make changes to this bug.