Autoscroller does not disengage when middle clicking anywhere other than the widget.

VERIFIED FIXED in Firefox 60

Status

()

defect
P1
normal
VERIFIED FIXED
Last year
Last year

People

(Reporter: lola_j22, Assigned: dao)

Tracking

({regression})

60 Branch
Firefox 61
Unspecified
Windows
Points:
---
Dependency tree / graph
Bug Flags:
in-qa-testsuite +

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox58 unaffected, firefox59 unaffected, firefox60+ verified, firefox61 verified)

Details

Attachments

(1 attachment)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20100101



Actual results:

There's no easy way to stop autoscrolling in the latest nightly, left click interacts with the content below the cursor, middle click repositions the autoscroller at the place that was clicked, right clicking creates a context menu and interacts with the page.


Expected results:

Middle clicking anywhere while the autoscroller is showing should stop autoscrolling, not reposition and continue autoscrolling.
[Tracking Requested - why for this release]:ux regression
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
[Tracking Requested - why for this release]:
Blocks: 1442651
Component: Untriaged → Tabbed Browser
Flags: needinfo?(dao+bmo)
I can't seem to reproduce this with my trackpad on Ubuntu. Wondering if this is platform-dependent or can only be reproduced with a mouse...
(In reply to Dão Gottwald [::dao] from comment #3)
> I can't seem to reproduce this with my trackpad on Ubuntu. Wondering if this
> is platform-dependent or can only be reproduced with a mouse...

yep, I am able to reprodice on Ubuntu16.04.

So, this probrem seems to be reproducible on windows only.
OS: Unspecified → Windows
oops,
s/I am able/I am NOT able/
One more discovery, the autoscroller behaves as expected on internal pages (about:) but not on actual web pages or about:reader.
I can also confirm it on Windows with 60b3 but not on Arch linux same version.
This regressed with bug 1442651 because that put the autoscroll popup in #mainPopupSet rather than some random place in the document, and now we hit this somewhat bogus-looking code path:

https://searchfox.org/mozilla-central/rev/8976abf9cab8eb4661665cc86bd355cd08238011/layout/xul/nsMenuPopupFrame.cpp#1851
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Flags: needinfo?(dao+bmo)
Duplicate of this bug: 1444845
Priority: -- → P1
Attachment #8959111 - Flags: review?(enndeakin)
Attachment #8959111 - Flags: review?(enndeakin) → review+
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/94cf9a609d44
Make the autoscroll popup explicitly consume outside clicks. r=enn
https://hg.mozilla.org/mozilla-central/rev/94cf9a609d44
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
Question as it appears to be targeting 61 for the patch, will it be included also in next 60betas?
Duplicate of this bug: 1446184
Duplicate of this bug: 1446224
(In reply to George Billios from comment #13)
> Question as it appears to be targeting 61 for the patch, will it be included
> also in next 60betas?

That's the goal but it hasn't landed in 60 yet.
Flags: qe-verify+
Comment on attachment 8959111 [details]
Bug 1443937 - Make the autoscroll popup explicitly consume outside clicks.

Approval Request Comment
[Feature/Bug causing the regression]: bug 1442651
[User impact if declined]: see comment 0
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: no
[Needs manual test from QE? If yes, steps to reproduce]: yes, see comment 0
[List of other uplifts needed for the feature/fix]: /
[Is the change risky?]: no
[Why is the change risky/not risky?]: trivial fix
[String changes made/needed]: /
Attachment #8959111 - Flags: approval-mozilla-beta?
Comment on attachment 8959111 [details]
Bug 1443937 - Make the autoscroll popup explicitly consume outside clicks.

regression fix for beta60
Attachment #8959111 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Build ID: 20180320100122
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

Verified as fixed on Firefox Nightly 61.0a1 on Windows 10 x 64, Windows 7 x32.
Status: RESOLVED → VERIFIED
I'm assuming the 60 status reset was accidental.
Updated by mistake status-firefox60.
Build ID: 20180322152034
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0

Verified as fixed on Firefox Beta 60.0b6 on Windows 10 x 64, Windows 7 x32.
Flags: qe-verify+
Flags: in-qa-testsuite+
You need to log in before you can comment on or make changes to this bug.