Closed Bug 1446184 Opened 3 years ago Closed 3 years ago

middle click scrolling doesn't turn off with middle click

Categories

(Firefox :: Untriaged, defect)

60 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1443937

People

(Reporter: sshock3, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180312152746

Steps to reproduce:

Middle-click and start scrolling around.  Then middle click again to turn it off.


Actual results:

It keeps scrolling; it just moves the circle overlay to the new position.


Expected results:

Stop scrolling (and circle overlay go away).

Note that just telling me to left click instead is not a solution.  Left click will actually invoke behavior of left clicking on something (e.g., a hyperlink), which I don't want.  I just want to turn off scrolling.

No, I don't want to have to go hit the escape key either.

This works correctly in all other browser, and in Firefox as well with 59 and earlier.  It broke in version 60.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1443937
You need to log in before you can comment on or make changes to this bug.