Closed Bug 1444140 Opened 2 years ago Closed 2 years ago

xdg-utils shouldn't be bundled in the firefox snap

Categories

(Release Engineering :: Release Automation: Other, defect)

defect
Not set

Tracking

(firefox60 fixed)

RESOLVED FIXED
Tracking Status
firefox60 --- fixed

People

(Reporter: ken.vandine, Assigned: ken.vandine)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20180305193205

Steps to reproduce:

Currently the firefox snap bundles xdg-utils, which includes the xdg-settings binary.  When attempting to set the default browser, we need firefox to use xdg-settings provided by the core snap.
Comment on attachment 8957232 [details]
Bug 1444140 - xdg-utils shouldn't be bundled in the firefox snap

https://reviewboard.mozilla.org/r/226162/#review232112

Sounds good to leave xdg-utils from the core snap.
Attachment #8957232 - Flags: review?(jlorenzo) → review+
Assignee: nobody → ken.vandine
Blocks: snappy
Comment on attachment 8957232 [details]
Bug 1444140 - xdg-utils shouldn't be bundled in the firefox snap

Approval Request Comment
[Feature/Bug causing the regression]: None
[User impact if declined]: Unable to set Firefox as a default browser while using an Ubuntu Snap package.
[Is this code covered by automated tests?]: N/A
[Has the fix been verified in Nightly?]: N/A. Releng crafts Snap on beta. Starting Firefox 59, Snap are also built on release.
[Needs manual test from QE? If yes, steps to reproduce]: No. This has been tested by Canonical's QA.
[List of other uplifts needed for the feature/fix]: N/A
[Is the change risky?]: No
[Why is the change risky/not risky?]: This is a Snap only fix for 59. It has no impact on the regular product.
[String changes made/needed]: None.
Attachment #8957232 - Flags: approval-mozilla-release?
We're sorry, Autoland could not rebase your commits for you automatically. Please manually rebase your commits and try again.

hg error in cmd: hg rebase -s 978854ae77fd808577d5670011b2b2e868aea550 -d c5650d15df01: rebasing 451295:978854ae77fd "Bug 1444140 - xdg-utils shouldn't be bundled in the firefox snap r=jlorenzo" (tip)
merging taskcluster/docker/firefox-snap/snapcraft.yaml.in
warning: conflicts while merging taskcluster/docker/firefox-snap/snapcraft.yaml.in! (edit, then use 'hg resolve --mark')
unresolved conflicts (see hg resolve, then hg rebase --continue)
We're sorry, Autoland could not rebase your commits for you automatically. Please manually rebase your commits and try again.

hg error in cmd: hg rebase -s 978854ae77fd808577d5670011b2b2e868aea550 -d 91d8b7ad008b: rebasing 451373:978854ae77fd "Bug 1444140 - xdg-utils shouldn't be bundled in the firefox snap r=jlorenzo" (tip)
merging taskcluster/docker/firefox-snap/snapcraft.yaml.in
warning: conflicts while merging taskcluster/docker/firefox-snap/snapcraft.yaml.in! (edit, then use 'hg resolve --mark')
unresolved conflicts (see hg resolve, then hg rebase --continue)
Pushed by jlorenzo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/61c2667914b7
xdg-utils shouldn't be bundled in the firefox snap r=jlorenzo
https://hg.mozilla.org/mozilla-central/rev/61c2667914b7
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Comment on attachment 8957232 [details]
Bug 1444140 - xdg-utils shouldn't be bundled in the firefox snap

Taking for 59rc3 since it doesn't affect anything we ship and doesn't require verification from our QE people.
Attachment #8957232 - Flags: approval-mozilla-release? → approval-mozilla-release+
Comment on attachment 8957232 [details]
Bug 1444140 - xdg-utils shouldn't be bundled in the firefox snap

Sorry, was told to punt on this for now to avoid possibly delaying the RC3 build.
Attachment #8957232 - Flags: approval-mozilla-release+ → approval-mozilla-release?
Comment on attachment 8957232 [details]
Bug 1444140 - xdg-utils shouldn't be bundled in the firefox snap

60 is on m-r now, too late for 59.
Attachment #8957232 - Flags: approval-mozilla-release? → approval-mozilla-release-
You need to log in before you can comment on or make changes to this bug.