Closed Bug 1445570 Opened 2 years ago Closed Last year

Ensure notifying the MozAfterPaint correctly without timer.

Categories

(Core :: Layout, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
mozilla64
Tracking Status
firefox61 --- disabled
firefox62 --- disabled
firefox63 --- disabled
firefox64 --- fixed

People

(Reporter: mantaroh, Assigned: mattwoodrow)

References

(Blocks 3 open bugs)

Details

Attachments

(2 files)

The bug 1419226 was going to remove the timer of MozAfterPaint. However, it affects many reftest and mochitest and so on, so bug 1419226 will land related test only. This bug tracks the removing the timer of MozAfterPaint.
Blocks: 1415065
Priority: P3 → P5
Mantaroh, can you please attach the relevant patches from bug 1419226 for posterity? Just the patch files as attachments will do, no need to use MozReview. Thanks.
Flags: needinfo?(mantaroh)
(In reply to Brian Birtles (:birtles) from comment #1)
> Mantaroh, can you please attach the relevant patches from bug 1419226 for
> posterity? Just the patch files as attachments will do, no need to use
> MozReview. Thanks.

OK. This patch is removing timer of MozAfterPaint patch.
After applying this patch, several test are fail. For example, reftest of webrender and intermittents.
WebRender's reftest failure will avoid by removing initial browser tab's blank attribute[1].
A failure of reftest intermittent will avoid by calling nsDOMWindowUtil::UpdateLayerTree() after finishing MozAfterPaint listener handler[2].

[1] https://hg.mozilla.org/try/rev/c6a12e9ea6fa82ca72243a5af15894f4897763ef
[2] https://hg.mozilla.org/try/rev/7ba26a37f99f578191159534dfba43a64965db06
Flags: needinfo?(mantaroh)
MozReview-Commit-ID: C7WICJ5Q0ES
Priority: P5 → P1
Assignee: nobody → matt.woodrow
Blocks: 1486876
Comment on attachment 9006441 [details]
Bug 1445570 - Remove EnsureEventualAfterPaint timer. r?tnikkel

Timothy Nikkel (:tnikkel) has approved the revision.
Attachment #9006441 - Flags: review+
Pushed by mwoodrow@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6fefaf842b05
Remove EnsureEventualAfterPaint timer. r=tnikkel
https://hg.mozilla.org/mozilla-central/rev/6fefaf842b05
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
Duplicate of this bug: 1486876
Blocks: 1490554
You need to log in before you can comment on or make changes to this bug.