Closed Bug 1445631 Opened 4 years ago Closed 4 years ago

Intermittent make[4]: *** Deleting file 'filename'

Categories

(Firefox Build System :: General, defect, P5)

3 Branch
defect

Tracking

(firefox61 fixed)

RESOLVED FIXED
mozilla61
Tracking Status
firefox61 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: ted)

References

Details

(Whiteboard: [stockwell infra])

Attachments

(1 file)

Whiteboard: [stockwell infra]
Duplicate of this bug: 1445413
Duplicate of this bug: 1445411
Duplicate of this bug: 1445424
Duplicate of this bug: 1445761
The files deleted are object files. First failure is at 2018-03-13 18:28 UTC. All results (ignore the earlier ones with relative paths): https://sql.telemetry.mozilla.org/queries/52055#table

Ted, any idea what's messing up those Linux build jobs and if this is a FBS or a Taskcluster issue? Thank you.
Severity: normal → major
Flags: needinfo?(ted)
bug 1445413 comment 2 has details and a potential fix in the crate that sccache uses. bug 1445761 comment 1 has other related info.

I'll update sccache to pick up the fix and land a patch to use that updated version in m-c.
Assignee: nobody → ted
Blocks: 1445218
Flags: needinfo?(ted)
Duplicate of this bug: 1446311
Attachment #8959635 - Flags: review?(core-build-config-reviews) → review?(cmanchester)
Comment on attachment 8959635 [details]
bug 1445631 - update sccache to pick up a fix in the jobserver crate.

https://reviewboard.mozilla.org/r/228444/#review234294
Attachment #8959635 - Flags: review?(cmanchester) → review+
Pushed by tmielczarek@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f9e45b228c63
update sccache to pick up a fix in the jobserver crate. r=chmanchester
https://hg.mozilla.org/mozilla-central/rev/f9e45b228c63
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
Version: Version 3 → 3 Branch
You need to log in before you can comment on or make changes to this bug.