Link to fennec-beta-latest is 404 on /firefox/android/beta/all/

RESOLVED FIXED

Status

defect
P1
major
RESOLVED FIXED
Last year
Last year

People

(Reporter: agibson, Assigned: jlorenzo)

Tracking

unspecified

Firefox Tracking Flags

(firefox59 unaffected, firefox60 fixed, firefox61 fixed)

Details

Attachments

(1 attachment)

Severity: normal → major
Looks like they're redirect to /fennec/ instead of /mobile/. I think this is a problem in the bouncer submission (as opposed to bouncer aliases, like we had with Firefox the other day).

Trying to get these fixed manually.
Assignee: nobody → jlorenzo
The root problem is in https://dxr.mozilla.org/mozilla-central/source/taskcluster/taskgraph/transforms/bouncer_submission.py#33 -- we use {product} as a substitution, where we should probably be using {stage_product}. (product == fennec, stage_product == mobile)
The links appear to be working again! Thanks!

Should we move this into another component and keep it open to track the fix of the root problem, or close this and open a new one for the larger fix? I'm fine either way.
Duplicate of this bug: 1446028
Component: Product Details → Release Automation
Product: www.mozilla.org → Release Engineering
QA Contact: catlee
Version: Production → unspecified
Comment on attachment 8959465 [details]
Bug 1445890 - Fennec: Fix bad FTP path on bouncer submission  a=release

https://reviewboard.mozilla.org/r/228266/#review234110
Attachment #8959465 - Flags: review?(mtabara) → review+
Pushed by jlorenzo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4dc6a0427030
Fennec: Fix bad FTP path on bouncer submission r=mtabara
(In reply to Johan Lorenzo [:jlorenzo] from comment #7)
> Landed on release at:
> https://hg.mozilla.org/releases/mozilla-beta/rev/
> 4fe0615c6be1744ad9cbdcb6c917fabfac094a88

I meant "landed on beta"
Backed out for failing taskcluster/taskgraph/transforms/bouncer_submission.py:33

backout: https://hg.mozilla.org/integration/autoland/rev/ee3711829e200f5a7bd92a4cf869b40931fc8a11

push with failure: https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=4dc6a042703058183ad367ae10f9e423d23b711a&selectedJob=168495033

failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=168495033&repo=autoland&lineNumber=230

[task 2018-03-16T13:22:23.693Z] executing ['bash', '-cx', 'cd /builds/worker/checkouts/gecko && ./mach lint -l flake8 -f treeherder']
[task 2018-03-16T13:22:23.708Z] + cd /builds/worker/checkouts/gecko
[task 2018-03-16T13:22:23.708Z] + ./mach lint -l flake8 -f treeherder
[task 2018-03-16T13:22:24.494Z] New python executable in /builds/worker/checkouts/gecko/obj-x86_64-pc-linux-gnu/_virtualenv/bin/python2.7
[task 2018-03-16T13:22:24.494Z] Also creating executable in /builds/worker/checkouts/gecko/obj-x86_64-pc-linux-gnu/_virtualenv/bin/python
[task 2018-03-16T13:22:25.962Z] Installing setuptools, pip, wheel...done.
[task 2018-03-16T13:22:27.091Z] running build_ext
[task 2018-03-16T13:22:27.091Z] building 'psutil._psutil_linux' extension
[task 2018-03-16T13:22:27.091Z] creating build
[task 2018-03-16T13:22:27.091Z] creating build/temp.linux-x86_64-2.7
[task 2018-03-16T13:22:27.092Z] creating build/temp.linux-x86_64-2.7/psutil
[task 2018-03-16T13:22:27.092Z] x86_64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fno-strict-aliasing -Wdate-time -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -fPIC -DPSUTIL_POSIX=1 -DPSUTIL_VERSION=543 -DPSUTIL_LINUX=1 -I/usr/include/python2.7 -c psutil/_psutil_common.c -o build/temp.linux-x86_64-2.7/psutil/_psutil_common.o
[task 2018-03-16T13:22:27.092Z] x86_64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fno-strict-aliasing -Wdate-time -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -fPIC -DPSUTIL_POSIX=1 -DPSUTIL_VERSION=543 -DPSUTIL_LINUX=1 -I/usr/include/python2.7 -c psutil/_psutil_posix.c -o build/temp.linux-x86_64-2.7/psutil/_psutil_posix.o
[task 2018-03-16T13:22:27.092Z] x86_64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fno-strict-aliasing -Wdate-time -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -fPIC -DPSUTIL_POSIX=1 -DPSUTIL_VERSION=543 -DPSUTIL_LINUX=1 -I/usr/include/python2.7 -c psutil/_psutil_linux.c -o build/temp.linux-x86_64-2.7/psutil/_psutil_linux.o
[task 2018-03-16T13:22:27.092Z] creating build/lib.linux-x86_64-2.7
[task 2018-03-16T13:22:27.092Z] creating build/lib.linux-x86_64-2.7/psutil
[task 2018-03-16T13:22:27.093Z] x86_64-linux-gnu-gcc -pthread -shared -Wl,-O1 -Wl,-Bsymbolic-functions -Wl,-Bsymbolic-functions -Wl,-z,relro -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -Wdate-time -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -Wl,-Bsymbolic-functions -Wl,-z,relro -Wdate-time -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security build/temp.linux-x86_64-2.7/psutil/_psutil_common.o build/temp.linux-x86_64-2.7/psutil/_psutil_posix.o build/temp.linux-x86_64-2.7/psutil/_psutil_linux.o -o build/lib.linux-x86_64-2.7/psutil/_psutil_linux.so
[task 2018-03-16T13:22:27.093Z] building 'psutil._psutil_posix' extension
[task 2018-03-16T13:22:27.093Z] x86_64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fno-strict-aliasing -Wdate-time -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -fPIC -DPSUTIL_POSIX=1 -DPSUTIL_VERSION=543 -DPSUTIL_LINUX=1 -I/usr/include/python2.7 -c psutil/_psutil_common.c -o build/temp.linux-x86_64-2.7/psutil/_psutil_common.o
[task 2018-03-16T13:22:27.093Z] x86_64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fno-strict-aliasing -Wdate-time -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -fPIC -DPSUTIL_POSIX=1 -DPSUTIL_VERSION=543 -DPSUTIL_LINUX=1 -I/usr/include/python2.7 -c psutil/_psutil_posix.c -o build/temp.linux-x86_64-2.7/psutil/_psutil_posix.o
[task 2018-03-16T13:22:27.094Z] x86_64-linux-gnu-gcc -pthread -shared -Wl,-O1 -Wl,-Bsymbolic-functions -Wl,-Bsymbolic-functions -Wl,-z,relro -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -Wdate-time -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -Wl,-Bsymbolic-functions -Wl,-z,relro -Wdate-time -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security build/temp.linux-x86_64-2.7/psutil/_psutil_common.o build/temp.linux-x86_64-2.7/psutil/_psutil_posix.o -o build/lib.linux-x86_64-2.7/psutil/_psutil_posix.so
[task 2018-03-16T13:22:27.094Z] copying build/lib.linux-x86_64-2.7/psutil/_psutil_linux.so -> psutil
[task 2018-03-16T13:22:27.094Z] copying build/lib.linux-x86_64-2.7/psutil/_psutil_posix.so -> psutil
[task 2018-03-16T13:22:27.094Z] 
[task 2018-03-16T13:22:27.094Z] Error processing command. Ignoring because optional. (optional:packages.txt:comm/build/virtualenv_packages.txt)
[task 2018-03-16T13:22:53.137Z] TEST-UNEXPECTED-ERROR | /builds/worker/checkouts/gecko/taskcluster/taskgraph/transforms/bouncer_submission.py:33:100 | line too long (103 > 99 characters) (E501)
[task 2018-03-16T13:22:53.137Z] TEST-UNEXPECTED-ERROR | /builds/worker/checkouts/gecko/taskcluster/taskgraph/transforms/bouncer_submission.py:213:1 | too many blank lines (3) (E303)
[taskcluster 2018-03-16 13:22:53.662Z] === Task Finished ===
[taskcluster 2018-03-16 13:22:53.662Z] Unsuccessful task run with exit code: 1 completed in 249.901 seconds
Flags: needinfo?(jlorenzo)
Pushed by jlorenzo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4ba64495f393
Fennec: Fix bad FTP path on bouncer submission r=mtabara a=release
Flags: needinfo?(jlorenzo)
https://hg.mozilla.org/mozilla-central/rev/4ba64495f393
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.