Closed Bug 1446276 Opened 4 years ago Closed 1 year ago

"Recommended by Pocket" in New Tab Preferences turns itself back on when Firefox updates

Categories

(Firefox :: Pocket, defect, P1)

59 Branch
defect

Tracking

()

RESOLVED FIXED
Firefox 78
Tracking Status
firefox78 --- fixed

People

(Reporter: mhughes, Assigned: thecount, NeedInfo)

References

Details

Attachments

(2 files, 1 obsolete file)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20180313132747

Steps to reproduce:

Allowed distro (Xubuntu 16.04 LTS) package manager to upgrade Firefox to 59.0.  Restarted Firefox, opened new tab.  This has happened on previous upgrades as well, though I don't have the version numbers.

about:config settings previously modified to try to fix this:
- extensions.pocket.api;localhost
- extensions.pocket.enabled;false
- extensions.pocket.site;localhost


Actual results:

"Recommended by Pocket" items present, and clicking gear icon shows "Recommended by Pocket" checkbox is checked.  Before upgrade, checkbox was clear and new tabs were empty.


Expected results:

New tab settings from previous version should be maintained.  "Recommended by Pocket" should have remained disabled, and checkbox should not have set itself.

I've just auto-updated to Firefox 72.0.1 and 'Recommended by Pocket' re-enabled itself.

I don't see it on a new tab, as Tridactyl extension has taken that over, but I do see it on a new window.

This is on MacOS 10.14.6

Actual results:

"Recommended by Pocket" items present, and clicking gear icon shows "Recommended by Pocket" checkbox is checked. Before upgrade, checkbox was clear and new windows were empty.

Expected results:

New window/tab settings from previous version should be maintained. "Recommended by Pocket" should have remained disabled, and checkbox should not have set itself.

Duplicate of this bug: 1607868

Thank you for reporting, Rik!

Scott, can you investigate?

Flags: needinfo?(sdowne)

The pref that's controlling this is: browser.newtabpage.activity-stream.feeds.section.topstories

It's somehow being reverted from a user set value to a default value, seemingly on every release. I haven't been able to reproduce this yet.

One thing that comes to mind that could cause this is Firefox sync, do you happen to be using that, or possibly using it without knowing it?

I'm not sure how Firefox sync would do this at the same point of an update, but to my knowledge there isn't another way for a user defined pref to flip like this.

Did this happen with the latest release (Fx 74 on 4/7)?

Flags: needinfo?(sdowne)
Flags: needinfo?(rik)
Flags: needinfo?(mhughes)

Yes

Flags: needinfo?(sdowne)

@micheal, are you using Firefox Sync?

Flags: needinfo?(sdowne)

No.

Do you have any other features in about:preferences#home turned off that are working fine, if not, is there one that you don't use, can temporarily turn it off too, and when a release happens, see if that feature also turns back on?

I'm trying to determine if this is an issue with just the Pocket feature, or if it's happening with other features, and we've only noticed it with Pocket. This helps narrow down the problem area.

I'll try that when the next update arrives.

I have only the first two options enabled. The only other option that turns on by itself during and update is the Pocket option. The others stay disabled.

Another thing that can help me figure out what's going wrong.

Do you mind taking and sending me a screenshot for what you see if you go to about:studies?

Attached image about_studies.jpg

See attachment (it's in German, but I think you'll get the important info)

Out of curiosity, for the people seeing this, if you go to about:policies, are there any active enterprise policies?

I disabled the search bar today, then upgraded to FF 75. The search bar stayed disabled. Curiously, the Pocket Reader option disappeared completely...

After updating the German language pack and restarting FF again, the Pocket Reader option re-appeared, and it was enabled again.

Hey Michael, so nothing looks out of place in about:studies.

Do you see anything in about:policies that you don't mind sharing?

There are no enterprise policies (this is on my private PC).

Hey Michael, a few more questions.

What is the Pocket Reader, do you mean the Pocket button next to the address bar?

You mentioned you downloaded a new lang pack. Presumably, you do that every release? Are there other post release things you need to do that might be creating the perfect storm?

Do you have any other pocket related prefs disabled, or no opted, that I could set on my end to try to reproduce the issue?

I've had pocket disabled for 2 releases now and having no issues yet. I'm missing a piece of this puzzle still.

Priority: -- → P5

This is about the "Recommended by Pocket" option in the home screen settings. It turns itself on with every FF update.

The language pack was updated because the old version was incompatible with FF 75. This normally does not occur. Normally it's just a plain FF update.

I also found https://www.reddit.com/r/firefox/comments/c7yaxd/pocket_keeps_reenabling_itself_on_the_new_tab_page/ but there was no new info there that we didn't try here, cept it seems to happen way more often for that user.

I consider this a last ditch solution, but I'm at a loss, can you try a new clean profile?

I'll try to remember this when the next update is released.

Hey Andrei and Rares.

I was directed to https://mana.mozilla.org/wiki/pages/viewpage.action?spaceKey=PI&title=PI+Request as a way to help get a bug validated.

In the above link, it mentions I can need info the two of you and you can help?

If that's the case, this particular bug , I cannot seem to reproduce it and otherwise have nothing that comes to mind on what could be causing it.

Anything you can find that might help me narrow it down would be awesome.

Happy to answer any questions!

Thanks

Flags: needinfo?(rares_bologa)
Flags: needinfo?(andrei.vaida)
Flags: needinfo?(rares_bologa)
Flags: needinfo?(cmuresan)
Flags: needinfo?(andrei.vaida)

Hey Scott,

I've tried my very best to try and get to the bottom of the scenarios listed here, but I've ran up against a wall. I tried using a VPN (3 to be more exact: Windscribe, Tunnelbear, and ProtonVPN) to set myself in the US so that I could naturally trigger the Recommended by Pocket section, but it's just not working. Every time I create a new profile the browser.search.region does not get set at all.

I've tried to work around this by setting the pref manually and updating after that with different outcomes depending on the Nightly version:

  • Nightly 59: I can see Stories, I turn them off via the control panel, update to the latest version (77) and the value of the browser.search.region pref is reset to RO.
  • Firefox 59 Release: same as above, the browser.search.region pref is reset.
  • Nightly 72: I can see Stories, I turn them off via about:preferences, update to the latest version, the values of the browser.search.region and the browser.newtabpage.activity-stream.feeds.section.topstories prefs remain unchanged.
  • Firefox 70 Release: same as above, both prefs remain unchanged.

@Michael, @Rik, and @Morgan could you please install Firefox Beta and check if this issue is reproducible whenever Beta gets an update? I'm curious if this happens because of the update and if so, if Beta's type of update can reproduce this?

Flags: needinfo?(cmuresan)

I installed Beta. Then the German language pack was again incompatible with this version, so even the option "Recommended by Pocket" did not show up in the settings (as already mentioned in an earlier comment). Then I updated the German language pack (with Beta), and after restarting FF both the settings option is back, and it is enabled.

Is the option reset by having an incompatible language pack or by updating it to a compatible version?

Hey Ciprian, interesting browser.search.region geo isn't being set. I've never set it naturally via a vpn, so I don't know how and if that would work, I usually just set it in the pref and restart. Do you suspect maybe that's a reason why we're not seeing this bug?

Also I think ideally we test this by setting to DE and not US, I doubt that's the issue though.

Hey Michael, yeah I've been wondering if there is something going on with lang packs causing this somehow, but I don't see how, nor could I reproduce by doing different things with lang packs. Once a pref is set by the user, as you would imagine, it shouldn't be able to change. So it's weird to say the least.

The more details you give on your usual release updates on lang packs, the better we can try to reproduce.

Hey Ciprian, interesting browser.search.region geo isn't being set. I've never set it naturally via a vpn, so I don't know how and if that would work, I usually just set it in the pref and restart. Do you suspect maybe that's a reason why we're not seeing this bug?

@Scott, I've been able to do this on older versions, yes. And yeah, I suspect it has something to do with how it automatically gets set. As you've mentioned once a pref is set by the user is should remain unchanged, and we (you and I at least) see that, but it might be because we're the ones setting the pref.

Is the option reset by having an incompatible language pack or by updating it to a compatible version?

@Michael, that's an interesting question, I can't say for sure that it might be the cause, but could you please take us through the install flow that you normally do? Where you get Firefox from, what locale it is originally, what you do to it, where do you take the language pack and how do you install it? These might help us track down a way to reliably reproduce the issue you're experiencing.

That's quite a short story. I usually install FF from Mozilla, and install the language pack from Mozilla's Addons. Then I update FF through the built-in update mechanism, and the language pack either updates itself, or I force an update via "check for updates" on the about:addons page.

So you're not installing a localized build from the get-go.
@Michael, are you installing an en-US version (or different from the language pack you're installing) of the browser before applying the language pack?

Because if so, the browser might be doing something along the lines of:

  • new Firefox version rolls out and gets installed
  • the addon is unsupported
  • even though the pref is false, we're not seeing Stories because the build/region combo is ineligible
  • the new version of the addon gets rolled out
  • the profile is now re-eligible to be shown Stories so the .feeds.section.topstories pref is changed from false to true

@Scott, would this scenario make sense?

Flags: needinfo?(sdowne)

I actually don't know. I've not installed FF from scratch for a long time. I can't remember what the initial version was.

Hey Criprian, I think you're right, and I think I've reproduced the issue. The steps are probably a variant to the steps impacting Michael, but I think the root of the problem is the same.

What I did:

  1. I'm In Canada, so I started with a CA region.
  2. Create a new profile. Should see stories.
  3. Turn off stories using the mechanism in about:preferences#home
  4. Restart the browser (not sure if this is needed, but it's what I did)
  5. Set region to DE (this part is important, and what I was missing in previous steps) We're now in a state of DE region in an en-CA browser. This state actually removes the pref (which also means stories are off), vs setting it to false, it seems. You can verify this at this after step 6 by checking about:preferences#home and you should see there is no longer an option to turn stories on or off. And you shouldn't see stories at this point.)
  6. Restart
  7. Now set region back to CA
  8. Restart

Stories are now back and I never set them to be back.

I think the root of the issue is this:

While we have a mechanism in place to ensure a user set pref cannot be changed to another value, it doesn't stop the value from being reset. Once it's reset, it can now be changed again, and the mechanism to prevent user changed prefs from being updated is no longer in place, because the pref is no longer user set.

Flags: needinfo?(sdowne)

I think I can fix the above set of steps in next release (78)!

Priority: P5 → P2

There was an update of Beta today, and the option stayed off during the update. However, the language pack was not updated.

That adds up.

Assignee: nobody → sdowne
Priority: P2 → P1
Pushed by sdowne@getpocket.com:
https://hg.mozilla.org/integration/autoland/rev/dd35edffc6df
Separate pref for user set topstories and system set topstories. r=gvn,k88hudson
Attachment #9146882 - Attachment is obsolete: true
Pushed by sdowne@getpocket.com:
https://hg.mozilla.org/integration/autoland/rev/b84687ef2bfd
Separate pref for user set topstories and system set topstories. r=gvn,k88hudson
Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 78
Regressions: 1649883
Flags: needinfo?(sdowne)
Regressions: 1726791
You need to log in before you can comment on or make changes to this bug.