Policy: network.negotiate-auth.trusted-uris, network.negotiate-auth.delegation-uris and network.automatic-ntlm-auth.trusted-uris

VERIFIED FIXED in Firefox 60

Status

()

defect
VERIFIED FIXED
a year ago
a year ago

People

(Reporter: mkaply, Assigned: mkaply)

Tracking

Trunk
Firefox 61
Points:
---

Firefox Tracking Flags

(firefox60+ verified, firefox61 verified)

Details

Attachments

(1 attachment)

(Assignee)

Description

a year ago
We need policies for network.negotiate-auth.delegation-uris, network.negotiate-auth.trusted-uris and network.automatic-ntlm-auth.trusted-uris

These are strings.

Docs are here:

https://developer.mozilla.org/en-US/docs/Mozilla/Integrated_authentication
(Assignee)

Updated

a year ago
Blocks: policies-mvp
(Assignee)

Updated

a year ago
Assignee: nobody → mozilla
Comment hidden (mozreview-request)

Comment 2

a year ago
mozreview-review
Comment on attachment 8964370 [details]
Bug 1446482 - Add policy for integrated auth prefs.

https://reviewboard.mozilla.org/r/233082/#review238522
Attachment #8964370 - Flags: review?(felipc) → review+
We're sorry, Autoland could not rebase your commits for you automatically. Please manually rebase your commits and try again.

hg error in cmd: hg rebase -s 0330387f4b9b060c5f3193633285fd1a43187498 -d 2ac2b364cf5d: rebasing 455743:0330387f4b9b "Bug 1446482 - Add policy for integrated auth prefs. r=Felipe" (tip)
merging browser/components/enterprisepolicies/Policies.jsm
merging browser/components/enterprisepolicies/schemas/policies-schema.json
merging browser/components/enterprisepolicies/tests/browser/browser_policies_simple_pref_policies.js
warning: conflicts while merging browser/components/enterprisepolicies/tests/browser/browser_policies_simple_pref_policies.js! (edit, then use 'hg resolve --mark')
unresolved conflicts (see hg resolve, then hg rebase --continue)
Comment hidden (mozreview-request)

Comment 5

a year ago
Pushed by mozilla@kaply.com:
https://hg.mozilla.org/integration/autoland/rev/173ac8b5a196
Add policy for integrated auth prefs. r=Felipe
(Assignee)

Updated

a year ago
Duplicate of this bug: 1441081

Comment 7

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/173ac8b5a196
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
[Tracking Requested - why for this release]:
Enterprise Policies
We tested this on Nightly with JSON policy format and it is verified as fixed.

This policy sets values to the three prefs (comment 0).

It will also be tested with adm formats when ready.
Test cases and runs are here- https://testrail.stage.mozaws.net/index.php?/plans/view/8760
Comment on attachment 8964370 [details]
Bug 1446482 - Add policy for integrated auth prefs.

Approval Request Comment
[Feature/Bug causing the regression]: Enterprise Policies
[User impact if declined]: Policy related to authentication prefs
[Is this code covered by automated tests?]: yes
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: -
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: no
[Why is the change risky/not risky?]: just configures prefs
[String changes made/needed]: none
Attachment #8964370 - Flags: approval-mozilla-beta?
Comment on attachment 8964370 [details]
Bug 1446482 - Add policy for integrated auth prefs.

enterprise policy, approved for 60.0b11
Attachment #8964370 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
We retested this on beta builds[FX60] with ADM and JSON policy formats and it is verified as fixed.

Test cases and runs are here- https://testrail.stage.mozaws.net/index.php?/plans/view/8760
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.