Closed Bug 1446667 Opened 6 years ago Closed 2 years ago

layout.display-list.retain cause a blink while scrolling

Categories

(Core :: Web Painting, defect)

58 Branch
x86
Windows 7
defect
Not set
major

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- disabled
firefox59 --- disabled
firefox60 + disabled
firefox61 - wontfix
firefox62 --- wontfix
firefox63 --- wontfix
firefox64 --- wontfix
firefox65 --- fix-optional

People

(Reporter: u614034, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: nightly-community, regression)

Attachments

(3 files)

Attached file about:support.txt
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180315232954

Steps to reproduce:

load any site
use mouse-wheel to scroll on screen at a time(run-> main.cpl ->wheel ->scroll one screen at a time in windows)
there is similar blink but fixed with layout.display-list.retain=false
I think the problem is gfx.webrender.all = true. The preferences is false by default in Beta60.
@reporter,
Could you try reset the pref(gfx.webrender.all)?
Flags: needinfo?(wado)
(In reply to Alice0775 White from comment #2)
> @reporter,
> Could you try reset the pref(gfx.webrender.all)?

Did same issue
Flags: needinfo?(wado) → needinfo?(alice0775)
(In reply to Emilio from comment #3)
> (In reply to Alice0775 White from comment #2)
> > @reporter,
> > Could you try reset the pref(gfx.webrender.all)?
> 
> Did same issue

Did you restart browser after reset the pref?  (Restarting browser is required for the settings to take effect.)

And Could you try with clean new profile?
Flags: needinfo?(alice0775) → needinfo?(wado)
(In reply to Alice0775 White from comment #4)
> (In reply to Emilio from comment #3)
> > (In reply to Alice0775 White from comment #2)
> > > @reporter,
> > > Could you try reset the pref(gfx.webrender.all)?
> > 
> > Did same issue
> 
> Did you restart browser after reset the pref?  (Restarting browser is
> required for the settings to take effect.)
> 
> And Could you try with clean new profile?

@Alice0775 
yes made a new profile, still the problem occurs!
toggling layout.display-list.retain=false fixes it or setting the mouse setting in windows to default.
Flags: needinfo?(wado) → needinfo?(alice0775)
Component: Untriaged → Graphics: Layers
Flags: needinfo?(alice0775)
Product: Firefox → Core
(In reply to Emilio from comment #0)
> Created attachment 8959850 [details]
> about:support.txt
> 
> User Agent: Mozilla/5.0 (Windows NT 6.1; rv:60.0) Gecko/20100101 Firefox/60.0
> Build ID: 20180315232954
> 
> Steps to reproduce:
> 
> load any site
> use mouse-wheel to scroll on screen at a time(run-> main.cpl ->wheel
> ->scroll one screen at a time in windows)
> there is similar blink but fixed with layout.display-list.retain=false

It's more like a pause which causes the blink until the page is redrawn
more visible on heavy sites or multiple heavy sites opened at once.
Component: Graphics: Layers → Layout: View Rendering
Component: Layout: View Rendering → Layout: Web Painting
Depends on: 1438374
Blocks: 1352499, 1416055
Severity: normal → major
Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
Has STR: --- → yes
Ever confirmed: true
OS: Unspecified → Windows 7
QA Contact: Virtual
Hardware: Unspecified → x86
Version: 60 Branch → 58 Branch
I can't reproduce this locally, how long does the flash usually last? Does it stay missing until you interact with the page again, or does it show up quickly after?
(In reply to Matt Woodrow (:mattwoodrow) from comment #8)
> I can't reproduce this locally, how long does the flash usually last? Does
> it stay missing until you interact with the page again, or does it show up
> quickly after?

Anywhere from 1sec to 3secs

See also Bug 1442573
Flags: needinfo?(matt.woodrow)
I'm wondering if this is a dupe of bug 1447193. Maybe not if 60 is also affected, but it's also not clear to me if this has actually been reproduced on 60 Beta builds or not. Emilio, is this still reproducible for you?
Flags: needinfo?(wado)
(In reply to Ryan VanderMeulen [:RyanVM] from comment #10)
> I'm wondering if this is a dupe of bug 1447193. Maybe not if 60 is also
> affected, but it's also not clear to me if this has actually been reproduced
> on 60 Beta builds or not. Emilio, is this still reproducible for you?

Firefox
Version 	60.0b11
Build ID 	20180409184545

still has the issues most visible if opening ten tabs at once and  using scrolling on one page it takes a pause then the page is rendered again
scroll one screen at a time in windows settings,smooth scroll is also disabled.
Flags: needinfo?(wado) → needinfo?(ryanvm)
 	Firefox
Version 	61.0a1
Build ID 	20180410220129

Also show the issue
set
scroll one screen at a time in windows mouse settings,smooth scroll to disabled
visit while page loads scroll using scroll button

http://news.softpedia.com/
Depends on: 1442573
even here, please note it happens on first scroll only after that it cannot be reproduced except reloading again.
Set
browser.tabs.remote.autostart;false

and/or 

layout.display-list.retain;false
Version: 58 Branch → 61 Branch
(In reply to Emilio from comment #11)
> still has the issues most visible if opening ten tabs at once and  using
> scrolling on one page it takes a pause then the page is rendered again
> scroll one screen at a time in windows settings,smooth scroll is also
> disabled.

Darn. Thanks for the update.
Flags: needinfo?(ryanvm)
(In reply to Ryan VanderMeulen [:RyanVM] from comment #16)
> (In reply to Emilio from comment #11)
> > still has the issues most visible if opening ten tabs at once and  using
> > scrolling on one page it takes a pause then the page is rendered again
> > scroll one screen at a time in windows settings,smooth scroll is also
> > disabled.
> 
> Darn. Thanks for the update.

Sure, hopefully can be fixed and merged to ESR60 soon
@ Emilio - Please abstain from adding bugs (especially completely unrelated) to "Depends on:" and "Blocks:". Thanks
No longer blocks: 801949, 1204549, 1409047, 1428993
No longer depends on: 1422274, 1442573
Version: 61 Branch → 58 Branch
(In reply to Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.) from comment #18)
> @ Emilio - Please abstain from adding bugs (especially completely unrelated)
> to "Depends on:" and "Blocks:". Thanks

Sorry looked like same
I still can't reproduce this, news.softpedia.com loads pretty much instantly and I can scroll the whole page without issues.

Could you try getting a performance profile for this, so we can see if it's just slow, or if it's waiting when it shouldn't be -  https://developer.mozilla.org/en-US/docs/Mozilla/Performance/Reporting_a_Performance_Problem
Flags: needinfo?(matt.woodrow)
(In reply to Emilio from comment #21)
> Old profile
> 
> https://perfht.ml/2Hmq5Ha
> 
> with webrender
> 
> https://perfht.ml/2qs1ebc
> 
> https://perfht.ml/2qt9BDJ

FYI - WebRender isn't stable and enabled be default yet, disable it to minimize preference noise.
layout.display-list.retain will be turned off for 60 in bug 1454509
Hi guys seem to have a similar problem with nightly61

so here is the performance profile

While 2 pages loading

https://perfht.ml/2qQXOhL

while 10 pages loading
https://perfht.ml/2qS5e4h

While completely loaded my session and seeing flicks while scrolling on every tab.
https://perfht.ml/2HK3419

Will Firefox web-render fix this

Should i keep running Nightly61 for telemetry?
Or revert to stable if you guys have the data.
Thank you for making Firefox


Mr.Ryan Mr.Matt can you look in this

Does not happen in Firefox60beta
Flags: needinfo?(ryanvm)
Flags: needinfo?(matt.woodrow)
Flags: needinfo?(dothayer)
Matt is the engineering owner for this feature.
Flags: needinfo?(ryanvm)
Flags: needinfo?(dothayer)
(In reply to Ryan VanderMeulen [:RyanVM] from comment #25)
> Matt is the engineering owner for this feature.

Thanks
Jason, it looks like the profiles from comment 24 no longer exist. Would you be willing to generate a new one on a Nightly build w/o WebRender enabled?
Flags: needinfo?(pevar)
Sorry for replying late, was on a camping trip
just returned so

so here is a quick performance profile 
https://perfht.ml/2wOHioV

did not test with the original session
Flags: needinfo?(pevar) → needinfo?(ryanvm)
Thanks, Jason. We'll see if any of our engineers with expertise in looking at these notice anything obvious in it.
Flags: needinfo?(ryanvm)
(In reply to Jason Mechelynck from comment #28)
> Sorry for replying late, was on a camping trip
> just returned so
> 
> so here is a quick performance profile 
> https://perfht.ml/2wOHioV
> 
> did not test with the original session

Fascinating! Basically all your threads are idle, except for the compositor itself (powering the async scrolling), and that's running *super* slow (up to a full second per frame).

For some reason it looks like you're getting WARP, the software implementation of D3D11, which is supposed to be disallowed (since it's slow!).

Does switching the pref layers.acceleration.disabled to true make things better for you?

We're tracking this specific issue in bug 1401268.
Flags: needinfo?(matt.woodrow)
Flags: needinfo?(pevar)
(In reply to Matt Woodrow (:mattwoodrow) from comment #30)
> (In reply to Jason Mechelynck from comment #28)
> > Sorry for replying late, was on a camping trip
> > just returned so
> > 
> > so here is a quick performance profile 
> > https://perfht.ml/2wOHioV
> > 
> > did not test with the original session
> 
> Fascinating! Basically all your threads are idle, except for the compositor
> itself (powering the async scrolling), and that's running *super* slow (up
> to a full second per frame).
> 
> For some reason it looks like you're getting WARP, the software
> implementation of D3D11, which is supposed to be disallowed (since it's
> slow!).

Would be a Lie if said understand what you mean.

> Does switching the pref layers.acceleration.disabled to true make things
> better for you?


No seems to spike the CPU more

> We're tracking this specific issue in bug 1401268.

So updated windows and Nightly to latest

rebooted

re run
so can you look into these


https://perfht.ml/2Iy279d
Flags: needinfo?(pevar) → needinfo?(dbolter)
look @ this too(especially toward the end/start)

https://perfht.ml/2IqCVFY
NI the wrong person
Flags: needinfo?(matt.woodrow)
pref layers.acceleration.disabled to true

look at the scrolling towards the end

https://perfht.ml/2IuIhvP
Assignee: nobody → matt.woodrow
Flags: needinfo?(dbolter)
While this whole situation still seems pretty interesting and odd, it also doesn't sound like something we'd expect to see much in the wild (and also not directly tied to RDL). Dropping Fx61 tracking status based on that, though I'd still consider a patch if the investigation leads to something.
Flags: behind-pref+
anyone landing a patch for this in 63?
Too late for 63/64. We could still take a patch for 65/66.
Too late to fix in 64. Marking this issue as fix-optional for 65; if you land a patch in nightly and think it's low-risk for beta, please request uplift.

@Matt is there anything left to do here or this ticket can be closed since there are no new updates for the last 3 years and it might not be relevant anymore? I cannot reproduce the issue on my Win7 or Win10.
Thanks!

The bug assignee didn't login in Bugzilla in the last 7 months and this bug has severity 'major'.
:miko, could you have a look please?
For more information, please visit auto_nag documentation.

Assignee: matt.woodrow → nobody
Flags: needinfo?(mikokm)
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(mikokm)
Flags: needinfo?(matt.woodrow)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.