Cannot customize about:preferences#home content when sync or preference searching is disabled

VERIFIED FIXED in Firefox 61

Status

()

defect
P2
normal
VERIFIED FIXED
a year ago
11 months ago

People

(Reporter: euthanasia_waltz, Assigned: Mardak)

Tracking

(Blocks 1 bug, {regression})

61 Branch
Firefox 62
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox59 unaffected, firefox60 unaffected, firefox61 verified, firefox62 verified)

Details

User Story

https://github.com/mozilla/activity-stream/compare/firefox-61b11...firefox-61b14

Attachments

(1 attachment)

Reporter

Description

a year ago
The section won't display when having at least
browser.preferences.search=false
or
identity.fxaccounts.enabled=false
Reporter

Updated

a year ago
Blocks: 1417155

Updated

a year ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
why is this important?
Flags: needinfo?(euthanasia_waltz)

Comment 2

a year ago
Because it was not visible I thought the 'Firefox Home Content' section was to be a future enhancement when about:preferences#home was enabled; only after trying a new profile I saw this was not the case and found this setting was the culprit after adding my customizations one by one.

Setting identity.fxaccounts.enabled=false has been mentioned elsewhere in order to disable the Sync features (Cloud paranoid here); it has no UI in about:preferences so it may not meet the 'important' criteria.

Comment 3

a year ago
Marking as a regression since it was possible to customize the new tab page in previous versions with Sync disabled.
Keywords: regression
See Also: → 1445028
Summary: about:preferences#home 'Firefox Home Content' depends on irrelevant settings → Cannot customize about:preferences#home content when sync or preference searching is disabled
Blocks: 1432589
Iteration: --- → 62.2 - Jun 4
Flags: needinfo?(euthanasia_waltz)
Priority: -- → P2
Is this just because we're listening for the "sync-pane-loaded" event to inject elements?
Assignee: nobody → edilee
Comment hidden (mozreview-request)

Comment 6

a year ago
mozreview-review
Comment on attachment 8982082 [details]
Bug 1447879 - Cannot customize about:preferences#home content when sync or preference searching is disabled.

https://reviewboard.mozilla.org/r/248126/#review254456

Works for me!
Attachment #8982082 - Flags: review?(khudson) → review+

Comment 7

a year ago
Pushed by edilee@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/0dc7bfc7b0c1
Cannot customize about:preferences#home content when sync or preference searching is disabled. r=k88hudson

Comment 8

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/0dc7bfc7b0c1
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62
Please request Beta approval on this when you get a chance.
Flags: qe-verify+
Flags: needinfo?(edilee)
The issue is no longer reproducible on the latest Nightly 62.0a1 (Build ID 20180604100129) on Windows 10 x64, Mac 10.12.6 and Ubuntu 16.04 x32. The "Firefox Home Content" section is still displayed when "browser.preferences.search" or "identity.fxaccounts.enabled" (or both) are set to false.
Status: RESOLVED → VERIFIED
Flags: qe-verify+

Comment 11

a year ago
Commit pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/2eeb2031a323ff3bf0a7685dfb0aef41ddfa21cb
chore(mc): Port Bug 1447879 - Cannot customize about:preferences#home content when sync or preference searching is disabled. r=k88hudson
Assignee

Comment 12

11 months ago
Comment on attachment 8982082 [details]
Bug 1447879 - Cannot customize about:preferences#home content when sync or preference searching is disabled.

Approval Request Comment
[Feature/Bug causing the regression]: Bug 1404890 first implementing Firefox Home content preferences used the existing pattern of waiting for sync prefs to load before adding more preferences.
[User impact if declined]: Unable to customize Firefox Home content
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Yes comment 10
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: A little
[Why is the change risky/not risky?]: There's a known talos regression bug 1466472, which currently is unresolved, but my investigation there is that we should accept the "regression" which is actually a improvement on when the preference content actually shows up to the user.
[String changes made/needed]: None
Flags: needinfo?(edilee)
Attachment #8982082 - Flags: approval-mozilla-beta?
Comment on attachment 8982082 [details]
Bug 1447879 - Cannot customize about:preferences#home content when sync or preference searching is disabled.

Fixes broken customization of Firefox Home. The Talos regression was deemed to not be an issue. Approved for 61.0b14.
Attachment #8982082 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
I managed to reproduce the initial issue on 61.0a1 (2018-03-24). I also can confirm that 61.0b14 build1 (20180614135649) is verified fixed across platforms (Windows 10 x64, Ubuntu 16.04 x64, macOS 10.12.6).
Flags: qe-verify+
Assignee

Updated

11 months ago
Blocks: 1471375
Assignee

Updated

11 months ago
User Story: (updated)
You need to log in before you can comment on or make changes to this bug.