Closed Bug 1448938 Opened 2 years ago Closed Last year

Console's mocha tests are failing

Categories

(DevTools :: Console, defect, P3)

defect

Tracking

(firefox61 wontfix, firefox62 wontfix, firefox63 wontfix, firefox64 fixed)

RESOLVED FIXED
Firefox 64
Tracking Status
firefox61 --- wontfix
firefox62 --- wontfix
firefox63 --- wontfix
firefox64 --- fixed

People

(Reporter: nchevobbe, Assigned: nchevobbe)

Details

Attachments

(1 file)

**Steps to reproduce**
1. run `cd devtools/client/webconsole/new-console-output/test && yarn test`


**Expected results**

Everything is green

**Actual results**

There's a test failing: 

>   1) Network message reducer:
>       networkMessagesUpdateById
>         adds fetched HTTP post data:
>     Error: Expected undefined to exist
>      at assert (node_modules/expect/lib/assert.js:29:9)
>      at Expectation.toExist (node_modules/expect/lib/Expectation.js:52:28)
>      at Context.it (store/network-messages.test.js:82:70)

---
Priority: -- → P3
Product: Firefox → DevTools
The error from Comment 0 was fixed by Bug 1486768, but the test are now failing because of Bug 1024913.
I'll post a patch soon
Assignee: nobody → nchevobbe
Status: NEW → ASSIGNED
Comment on attachment 9009587 [details]
Bug 1448938 - Set fixture pref for reverse search in mocha tests; r=Honza.

Jan Honza Odvarko [:Honza] has approved the revision.
Attachment #9009587 - Flags: review+
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5c8ae3b994b5
Set fixture pref for reverse search in mocha tests; r=Honza.
https://hg.mozilla.org/mozilla-central/rev/5c8ae3b994b5
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
You need to log in before you can comment on or make changes to this bug.