Address bar -> Bookmark editor -> Tags: text box -> Tags: auto-completion feature is broken

RESOLVED FIXED in Firefox 60

Status

()

defect
P1
normal
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: CKOTTMozillaBugzilla, Assigned: masayuki)

Tracking

({regression})

60 Branch
Firefox 61
Unspecified
All
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox59 unaffected, firefox60+ fixed, firefox61 fixed)

Details

(Whiteboard: [fxsearch])

Attachments

(1 attachment)

Reporter

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20180315233128

Steps to reproduce:

*Given: (3) tags that begin with an uppercase 'A' are defined: 'Apple', 'Avery', 'Azure'

In address bar:
- Click on the star icon to open the bookmark editor
- Click on the Tags: text box
- Type a lowercase 'a'
- - - Notice: 'apple', with a lowercase 'a', is copied to the Tags: text box
- Press down arrow three times, to highlight 'Azure' in the Tags: autocomplete dropdown
- - - Notice: The Tags: text box still contains 'apple'
- Press Enter



Actual results:

- The bookmark editor immediately disappears
- The bookmark is now tagged with 'apple', with a lowercase 'a'
- The previously-defined tag named 'Apple' (with an uppercase 'A') has been changed to 'apple' (with a lowercase 'a')



Expected results:

- The bookmark editor remains open
- The Tags: autocomplete dropdown disappears
- 'Azure', with an uppercase 'A', is copied to the Tags: text box

(this is the behavior of version 59.x and prior versions)

Updated

a year ago
Status: UNCONFIRMED → NEW
Component: Untriaged → Bookmarks & History
Ever confirmed: true
Keywords: regression

Comment 1

a year ago
[Tracking Requested - why for this release]:the tag system is broken.
This is probably due to moving from tree autocomplete to richlistbox autocomplete, the behavior is surely slightly different, we must check it out and see what we can do. Anyway we are working on a tags refactoring for 61, I can't tell if we can easily fix this in 60, it's likely it may need autocomplete changes that may be scary for an uplift.
For now to complete you can use the Right arrow key.
Blocks: 1427366
Priority: -- → P1
Whiteboard: [fxsearch]

Comment 3

a year ago
Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=8fa7c8455f707d4fa36a01469ae24af6ad0cde02&tochange=c0b4ca69376c1b8cd1c22a202100363631b5b9a6

Regressed by;
c0b4ca69376c	Masayuki Nakano — Bug 1434837 - Make autocomplete and satchel listen to keypress event at the system event group r=mak

@:masayuki
Your patch seems to cause the regression, can you look into this?
Blocks: 1434837
Flags: needinfo?(masayuki)
thanks for checking
No longer blocks: 1427366
Assignee: nobody → masayuki
Status: NEW → ASSIGNED
Flags: needinfo?(masayuki)
Comment hidden (mozreview-request)

Comment 8

a year ago
mozreview-review
Comment on attachment 8962699 [details]
Bug 1449018 - The bookmark panel should listen to keypress event at the system event group

https://reviewboard.mozilla.org/r/231508/#review237442

Thank you, please ask for uplift approval once possible.
Attachment #8962699 - Flags: review?(mak77) → review+

Comment 9

a year ago
Pushed by masayuki@d-toybox.com:
https://hg.mozilla.org/integration/autoland/rev/e9ff0123aa27
The bookmark panel should listen to keypress event at the system event group r=mak

Comment 10

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/e9ff0123aa27
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
Comment on attachment 8962699 [details]
Bug 1449018 - The bookmark panel should listen to keypress event at the system event group

Approval Request Comment
[Feature/Bug causing the regression]:
Regression of bug 1434837.

[User impact if declined]:
Cannot use autocomplete in the bookmark panel (no problem with property dialog of bookmark item).

[Is this code covered by automated tests?]:
Yes.

[Has the fix been verified in Nightly?]:
Yes.

[Needs manual test from QE? If yes, steps to reproduce]: 
No since tested by new automated tests.

[List of other uplifts needed for the feature/fix]:
No.

[Is the change risky?]:
No.

[Why is the change risky/not risky?]:
Enter key and Escape key is handled by the bookmark panel directly. I.e., not changing common widget of toolkit or something.

[String changes made/needed]:
No.
Attachment #8962699 - Flags: approval-mozilla-beta?
Comment on attachment 8962699 [details]
Bug 1449018 - The bookmark panel should listen to keypress event at the system event group

one-line fix for bookmark panel, approved for 60.0b8
Attachment #8962699 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.