While mousebutton depressed to scrollbar + popup warning or other event, Mozilla doesn't yield mousefocus

RESOLVED DUPLICATE of bug 48037

Status

SeaMonkey
UI Design
RESOLVED DUPLICATE of bug 48037
16 years ago
13 years ago

People

(Reporter: Mike Neman, Assigned: Samir Gehani)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0+) Gecko/20020505
BuildID:    2002050521

I don't have a mouse wheel.
Say I'm holding down the mouse button on the scrollbar.
Then along comes e.g. a notice telling me a webpage has been updated and to ask
me whether I want to go look at it.
But if I move my mouse you see the webpage you were browsing still moving around.

Another example: my GAIM buddy sends me a note, my IceWM thus focusses instantly
on GAIM. When I return to MOzilla it's currently browsed webpage is moving to
the rhythm of my mouse moving WITHOUT my holding down any mousebuttons.


Reproducible: Always
Steps to Reproduce:
1. Set Page refresh for bookmark on short interval for a frequently updated
webpage like a forum page.
2. keep mousebutton pressed upon scrollbar and wait until message pops up
3. release all mousebuttons and move mouse around

Expected Results:  Should've yielded focus

Comment 1

16 years ago
bug 56240 is resolved as fixed, but this looks like a dup.
There are other variants of this bug too - see dependencies in meta bug 67277
reporter (Mike666): can you reproduce this bug with a recent build of mozilla
(for example, 1.1beta)? if so, please comment again with details. if not, please
resolve this bug as WORKSFORME. thanks.
(Reporter)

Comment 3

15 years ago
Sorry for the late reply, just back from holidays.
On-topic:
1.1BETA still has it (it hasn't proven annoying to me at all anymore actually)
I CANNOT reproduce the occasional popups to tell if a build has fixed this, but
another easy way to test it is to:
1. Lclick on the scrollbar **and hold**
2. move mouse over webpage area
3. Rclick inside area to open a menu
4. release all mouse buttons
5. move mouse over webpage area--> focus still on scrollbar except when pointer
moves over menu opened by Rclick.

I must admit that I don't know whether I'm talking about 2 different bugs here
or not. (e.g. ONE that occurs purely with user input inside Moz and ANOTHER
which is triggered by ad pop-ups/error messages from other apps. Same thing
happens in both cases.)
ah yes, that I can reproduce. Maybe one of our "onmouseout lost" bugs?

Comment 5

15 years ago
I also see this problem.  My platform is BSD/OS 4.3, and the browser
is a a build from yesterday (20020815).

Using the following steps (very, very similar to the steps in comment
#3):

- left click on scrollbar and hold
- move mouse into main browser window
- right click, and release
- release left mouse button

Note at this point that the scroll action for the window follows the mouse
pointer.  Note that the pop window is still present.

- right click and release

Note that the scroll action for the window still follows the mouse motion.

Comment 6

15 years ago
*** Bug 185986 has been marked as a duplicate of this bug. ***

Comment 7

15 years ago

*** This bug has been marked as a duplicate of 48037 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.