Closed Bug 1451006 Opened 2 years ago Closed 2 years ago

FX_PREFERENCES_CATEGORY_OPENED_V2 Histogram Regression on 03-20-2018

Categories

(Firefox :: New Tab Page, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Firefox 61
Iteration:
61.2 - Apr 9
Tracking Status
firefox-esr52 --- unaffected
firefox59 --- unaffected
firefox60 --- unaffected
firefox61 --- fixed

People

(Reporter: jaws, Assigned: k88hudson)

References

Details

(Keywords: regression)

Attachments

(1 file)

Seen here,
http://alerts.telemetry.mozilla.org/index.html#/detectors/1/metrics/2277/alerts/?from=2018-03-20&to=2018-03-20

The "unknown" category jumped from 0 to 0.46.

Regression range:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c8dbb4ed05f38f40ef3607a6e36545bd95b8a287&tochange=025426a3e2e780d33bb666c78bfbaf22b3456c19

I believe that "home" is not being used as a category for this probe which is causing this spike.

Adding needinfo to k88hudson and mardak, as this is likely from either bug 1446053 or bug 1447153.
Flags: needinfo?(khudson)
Flags: needinfo?(edilee)
I don't really see how bug 1447153 could be involved - it's purely in the stylesheet for browser.xul, and doesn't impact how about:preferences is loaded at all... I'm going to tentatively unhook the bugs for now, unless you're seeing something I'm not.
No longer blocks: 1447153
Ah, that's because I had a typo in my bug numbers! :)
Blocks: 1447155
Blocks: 1417155
No longer blocks: 1447155
Yep, I'll take a look. Thanks!
Assignee: nobody → khudson
Iteration: --- → 61.2 - Apr 9
Flags: needinfo?(khudson)
Priority: -- → P1
Flags: needinfo?(edilee)
Comment on attachment 8964691 [details]
Bug 1451006 - Send correct category for about:preferences#home telemetry

https://reviewboard.mozilla.org/r/233384/#review239296

The "home" category isn't included in the list of labels at https://searchfox.org/mozilla-central/rev/a0665934fa05158a5a943d4c8b277465910c029c/toolkit/components/telemetry/Histograms.json#6405-6414

You'll need to add it to the list there. We should be fine with the current expiration of v66.
Attachment #8964691 - Flags: review?(jaws) → review-
Comment on attachment 8964691 [details]
Bug 1451006 - Send correct category for about:preferences#home telemetry

https://reviewboard.mozilla.org/r/233384/#review239482

Note that this will cause problems comparing data from before this lands to data after this lands. I don't think there is any way around it though.
Attachment #8964691 - Flags: review?(jaws) → review+
That makes sense. Is there documentation or a chart somewhere I can leave a note/annotation if it would be helpful?
Pushed by khudson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5c12cad13a37
Send correct category for about:preferences#home telemetry r=jaws
(In reply to Kate Hudson :k88hudson from comment #9)
> That makes sense. Is there documentation or a chart somewhere I can leave a
> note/annotation if it would be helpful?

I don't think so but maybe Frank will know?
Flags: needinfo?(fbertsch)
> That makes sense. Is there documentation or a chart somewhere I can leave a
> note/annotation if it would be helpful?

We only support adding a new category to the _END_ of the `"labels"` array.

You can document it by adding this bug to the `"bug_numbers"` array.
Flags: needinfo?(fbertsch) → needinfo?(khudson)
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/07e5814d8e22
Send correct category for about:preferences#home telemetry r=jaws
https://hg.mozilla.org/mozilla-central/rev/07e5814d8e22
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
Thanks jaws!
Flags: needinfo?(khudson)
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.