Restore the <toolbarbutton type="menu-button"/> binding after its removal in bug 1434860

RESOLVED FIXED in Thunderbird 61.0

Status

enhancement
RESOLVED FIXED
Last year
Last year

People

(Reporter: Paenglab, Assigned: Paenglab)

Tracking

(Blocks 1 bug)

unspecified
Thunderbird 61.0
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Bug 1434860 removed the <toolbarbutton type="menu-button"/> binding. We use it a lot on different places.
I decided to add the binding to toolbar.xml instead of creating a new toolbabutton.xml for only this binding. This button relates also to toolbars.

Made a quick check and all buttons look like before. Can't say if it works on calendar too because it's not working in TB 61 but it should as it also load messenger.css.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8964785 - Flags: review?(jorgk)
Adding SM people as they need this binding too.
Summary: Restore the <toolbarbutton type="menu-button"/> binding after it's removal in bug 1434860 → Restore the <toolbarbutton type="menu-button"/> binding after its removal in bug 1434860
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/5ff3ad7b4050
Restore the <toolbarbutton type="menu-button"/> binding after its removal in bug 1434860. r=jorgk
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 61.0
Comment on attachment 8964785 [details] [diff] [review]
menu-button-binding.patch

Thanks!
Attachment #8964785 - Flags: review?(jorgk) → review+
Duplicate of this bug: 1445993
You need to log in before you can comment on or make changes to this bug.