Closed Bug 1451287 Opened 3 years ago Closed 2 years ago

EXT_shader_texture_lod is not supported, but it's marked as it was

Categories

(Core :: Canvas: WebGL, defect, P3)

59 Branch
All
Android
defect

Tracking

()

RESOLVED DUPLICATE of bug 1524804
Tracking Status
fennec ? ---
firefox59 --- affected
firefox60 --- affected
firefox61 --- affected

People

(Reporter: soadzoor, Unassigned)

References

Details

(Whiteboard: [gfx-noted])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.181 Safari/537.36

Steps to reproduce:

I opened up this page: https://threejs.org/examples/webgl_loader_gltf_extensions.html

When I select a PBR model, it doesn't appear.


Actual results:

The model doesn't appear, and the console log showed an error about EXT_shader_texture_lod (see attached screenshots).



Expected results:

First, I thought it's an issue of three.js framework, see this: https://github.com/mrdoob/three.js/issues/13765

It turns out, it's probably a problem in firefox for android.
Status: UNCONFIRMED → NEW
tracking-fennec: --- → ?
Component: General → Canvas: WebGL
Ever confirmed: true
OS: Unspecified → Android
Product: Firefox for Android → Core
Hardware: Unspecified → All
Version: Firefox 59 → 59 Branch
Duplicate of this bug: 1456130
What are you using to find out that the extension is supported?
Flags: needinfo?(soadzoor)
Ah your extension results here: https://github.com/mrdoob/three.js/issues/13765#issuecomment-378560321

jgilbert, what would cause this mismatch to occur?
Flags: needinfo?(soadzoor) → needinfo?(jgilbert)
Priority: -- → P3
Whiteboard: [gfx-noted]

This could be the reason why this web site fails in Firefox Android?
https://github.com/webcompat/web-bugs/issues/26281

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(jgilbert)
Resolution: --- → DUPLICATE
Duplicate of bug: webgl1-es2

(In reply to Karl Dubost💡 :karlcow from comment #4)

This could be the reason why this web site fails in Firefox Android?
https://github.com/webcompat/web-bugs/issues/26281

Retest with a recent Nightly, and it will be fixed if so!

working in this morning nightly. Thanks!

You need to log in before you can comment on or make changes to this bug.