build failure: ENOTSUP undeclared

RESOLVED FIXED in mozilla1.2

Status

Directory
LDAP C SDK
P3
normal
RESOLVED FIXED
16 years ago
15 years ago

People

(Reporter: hacker formerly known as seawood@netscape.com, Assigned: hacker formerly known as seawood@netscape.com)

Tracking

other
mozilla1.2
x86
OpenBSD

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed on ldap trunk, csdk50client branch])

Attachments

(2 attachments)

I'm hitting this error on the new OpenBSD 3.0 tinderbox:
http://tinderbox.mozilla.org/showlog.cgi?log=MozillaTest/1021593060.29830.gz&fulltext=1

gcc -o ldappr-error.o -c     -ansi -Wall -pthread -O -fPIC  -UDEBUG 
-DMOZILLA_CLIENT=1 -DNDEBUG=1 -DXP_UNIX=1 -DOPENBSD=1 -DHAVE_BSD_FLOCK=1
-DHAVE_LCHOWN=1 -DHAVE_STRERROR=1 -D_THREAD_SAFE=1  -DFORCE_PR_LOG
-D_PR_PTHREADS -UHAVE_CVAR_BUILT_ON_SEM -DUSE_WAITPID -DNEEDPROTOS    -DNET_SSL
 -DNO_LIBLCACHE -DLDAP_REFERRALS     -DNS_DOMESTIC 
-I/builds/tinderbox/SeaMonkey/OpenBSD_3.0_Depend/mozilla/obj-i386-pc-openbsd3.0/dist/public/ldap
-I/builds/tinderbox/SeaMonkey/OpenBSD_3.0_Depend/mozilla/directory/c-sdk/ldap/include
-I/builds/tinderbox/SeaMonkey/OpenBSD_3.0_Depend/mozilla/obj-i386-pc-openbsd3.0/dist/./include
-I/builds/tinderbox/SeaMonkey/OpenBSD_3.0_Depend/mozilla/obj-i386-pc-openbsd3.0/dist/include/nspr
 /builds/tinderbox/SeaMonkey/OpenBSD_3.0_Depend/mozilla/directory/c-sdk/ldap/libraries/libprldap/ldappr-error.c
/builds/tinderbox/SeaMonkey/OpenBSD_3.0_Depend/mozilla/directory/c-sdk/ldap/libraries/libprldap/ldappr-error.c:199:
`ENOTSUP' undeclared here (not in a function)
/builds/tinderbox/SeaMonkey/OpenBSD_3.0_Depend/mozilla/directory/c-sdk/ldap/libraries/libprldap/ldappr-error.c:199:
initializer element is not constant
/builds/tinderbox/SeaMonkey/OpenBSD_3.0_Depend/mozilla/directory/c-sdk/ldap/libraries/libprldap/ldappr-error.c:199:
(near initialization for `prldap_errormap[8].erm_system')
/builds/tinderbox/SeaMonkey/OpenBSD_3.0_Depend/mozilla/directory/c-sdk/ldap/libraries/libprldap/ldappr-error.c:229:
`EOVERFLOW' undeclared here (not in a function)
/builds/tinderbox/SeaMonkey/OpenBSD_3.0_Depend/mozilla/directory/c-sdk/ldap/libraries/libprldap/ldappr-error.c:229:
initializer element is not constant
/builds/tinderbox/SeaMonkey/OpenBSD_3.0_Depend/mozilla/directory/c-sdk/ldap/libraries/libprldap/ldappr-error.c:229:
(near initialization for `prldap_errormap[38].erm_system')
/builds/tinderbox/SeaMonkey/OpenBSD_3.0_Depend/mozilla/directory/c-sdk/ldap/libraries/libprldap/ldappr-error.c:233:
`EDEADLOCK' undeclared here (not in a function)
/builds/tinderbox/SeaMonkey/OpenBSD_3.0_Depend/mozilla/directory/c-sdk/ldap/libraries/libprldap/ldappr-error.c:233:
initializer element is not constant
/builds/tinderbox/SeaMonkey/OpenBSD_3.0_Depend/mozilla/directory/c-sdk/ldap/libraries/libprldap/ldappr-error.c:233:
(near initialization for `prldap_errormap[42].erm_system')
gmake[7]: *** [ldappr-error.o] Error 1
-> dmose
Assignee: mcs → dmose
Keywords: mozilla1.0
Hardware: Macintosh → PC
Created attachment 83986 [details] [diff] [review]
Add || defined(OPENBSD) as necessary

Comment 3

16 years ago
Comment on attachment 83986 [details] [diff] [review]
Add || defined(OPENBSD) as necessary

r=dmose
Attachment #83986 - Flags: review+
This patch has been checked into the ldap trunk and the csdk 50 client branch.
Blocks: 138348
Whiteboard: [fixed on ldap trunk, csdk50client branch]

Comment 5

16 years ago
This also affects NetBSD.  They have a patch available at
http://cvsweb.netbsd.org/bsdweb.cgi/pkgsrc/www/mozilla/patches/patch-bj.

Comment 6

16 years ago
why not do #ifndef ENOTSUP instead of checking for os's known not to have the 
def?

Comment 7

16 years ago
David: the NetBSD build problems are already covered by a fix in another bug
(bug 135027).

Timeless: a good idea for a future cleanup of this file.
Created attachment 84975 [details] [diff] [review]
Fix missing runtime symbols error

Bah.  The previous patch got it to compile but once we got something running
that used ldap, we have missing symbol errors.	OpenBSD needs the same ifdefs
that pretty much every platform needs so that symbols are resolved at link
time.
Please land this on the 1.0.1 branch.  Once there, replace the
"mozilla1.0.1+" keyword with the "fixed1.0.1" keyword.

(I'm assuming that both of the patches have already been checked into
the trunk.  It's not entirely clear.)
Keywords: mozilla1.0.1+
Re-assigning to cls, with his permission.
Assignee: dmose → seawood
Removing nominations.  The second patch hasn't even landed on the trunk yet and
Moz still has issues running on OpenBSD.
Keywords: mozilla1.0, mozilla1.0.1+
Priority: -- → P3
Target Milestone: --- → mozilla1.1
Target Milestone: mozilla1.1 → mozilla1.2
*** Bug 160428 has been marked as a duplicate of this bug. ***
Comment on attachment 84975 [details] [diff] [review]
Fix missing runtime symbols error

r=dmose
Attachment #84975 - Flags: review+
Patch has been checked into the ldap trunk & the csdk50client branch.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 15

15 years ago
Spam for bug 129472
QA Contact: nobody → nobody
You need to log in before you can comment on or make changes to this bug.