Closed Bug 1452203 Opened 5 years ago Closed 5 years ago

Debugger release v19.6 for FF60 Beta

Categories

(DevTools :: Debugger, enhancement, P3)

enhancement

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: jdescottes, Unassigned)

References

Details

Attachments

(1 file, 1 obsolete file)

Compare: https://github.com/devtools-html/debugger.html/compare/release-19.5...release-19.6

This patch is dedicated to workaround the Fennec debugging issue introduced in v59 and described in Bug 1443550
Attached patch patch-debugger-v19.6-rc1.patch (obsolete) — Splinter Review
Try is at: https://treeherder.mozilla.org/#/jobs?repo=try&revision=e0022e3b649da03924d98955a272304a89124a72

The commits cherry picked here are landing in Nightly with v32 (Bug 1451314). Waiting for v32 to land before moving forward here.
Comment on attachment 8966890 [details] [diff] [review]
patch-debugger-v19.6-rc2.patch

First of all, I really tried to make the diff smaller, but no matter what I do, since I am adding a new module, webpack is shifting almost everything in the file... You can have a look at the github changelog to get a better idea of the actual code change here: 
https://github.com/devtools-html/debugger.html/compare/release-19.5...release-19.6

Approval Request Comment
[Feature/Bug causing the regression]: Workaround for issue described in Bug 1443550
[User impact if declined]: Users can not use the debugger to remote debug Fennec 59 or Fennec 60.
[Is this code covered by automated tests?]: no (remote debugging is not covered)
[Has the fix been verified in Nightly?]: I manually tested it
[Needs manual test from QE? If yes, steps to reproduce]: 
- setup remote debugging on android (https://developer.mozilla.org/en-US/docs/Tools/Remote_Debugging/Debugging_Firefox_for_Android_with_WebIDE)
- open WebIDE
- connect to the mobile device
- switch to debugger -> debugger UI should appear
[List of other uplifts needed for the feature/fix]: Bug 1448499, already uplifted
[Is the change risky?]: No
[Why is the change risky/not risky?]: debugger/devtools only, we are just fetching the version of the debug target before sending another request (which crashes on some versions, crashes that we now can avoid)
[String changes made/needed]: none
Attachment #8966890 - Flags: review?(jlaster)
Attachment #8966890 - Flags: approval-mozilla-beta?
Comment on attachment 8966890 [details] [diff] [review]
patch-debugger-v19.6-rc2.patch

Cancelling requests for now, it seems this change breaks service worker debugging.
Attachment #8966890 - Flags: review?(jlaster)
Attachment #8966890 - Flags: approval-mozilla-beta?
We will let this ride the trains.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
Assignee: jdescottes → nobody
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.